Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Questwizard

Crashes/Lockups When Loading Maps

Recommended Posts

Product: Doom Builder version 1.68 build 385

Short Summary: Whenever I try to load a map up in Doom Builder, the loading procedure goes fine until it reaches the Optimizing Data Structures stage, then Doom Builder will load the map corrupted, lock the computer up, or crash out with an error message.

Steps to Reproduce:

Ok. This is going to be a lot of steps, but its the only way I can get this bug to show up.

1) Open up the Control Panel, and go to Regional and Language Options.
2) Go to the Languages tab, and check the box to install files for East Asian languages, and let it do its thing.
3) Reboot, and go back into the Regional and Language Options again.
4) On the Regional Options tab, choose Japan in the Location dropdown, and Japanese in the Standards and formats dropdown.
5) On the Languages tab, click the Details button.
6) Click the Add... button, and change the following settings:
Input language: Japanese
Check the Keyboard Layout/IME box, and choose Japanese.
If you have MS Office installed, also choose Drawing Pad under Handwriting recognition if it allows you to.
7) Click Ok, and in the Default input language dropdown, choose Japanese - Microsoft IME Standard 2002 ver. 8.1, and click Ok.
8) On the Advanced tab, choose Japanese as the Language for non-Unicode programs, click Ok, and reboot when it asks.
9) Finally, its time to start up Doom Builder, While you're at it, go ahead and go to File → Open Map...
10) Pick a WAD of your choice. it doesn't matter which one, and open it.
11) Change any settings if necessary for the WAD you are loading, and then hit Ok.
12) Be prepared to possibly have to reboot the computer, because it may lock up for a VERY LONG TIME.

Bug in Detail:
When you hit Ok, I can guarantee one of the following is going to happen 99% of the time once it reaches the Optimizing Data Structures stage:

1) Lockup for either a short or long amount of time, and load the map, but with hundreds or even thousands of warnings and errors, and the map loads up totally corrupted.
2) Lock the computer up completely, to the point where a reboot is the only way to stop it.
3) Lockup for either a short or long amount of time, and show the following error: "Error 6 while loading map: Overflow"

Changing all the regional settings back to what you had them normally completely gets rid of this bug, so apparently Doom Builder doesn't like Windows Codepage 932 (Japanese Shift-JIS) very well.

Related Files: None/Doesn't matter. They all crash or lock up anyway.

System Specifications:

CPU: AMD Athlon64 3500+
RAM: 1GB Dual Channel DDR1
Video: 2X nVidia GeForce 7600GS: SLI Enabled
--------------------
I sure hope there's a fix for this, becuase its very annoying having to switch all those regional and language settings back to English just to get Doom Builder to load up even the simplest maps. BTW, AppLocale didn't help even when I ran it in English mode with that.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×