Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Error while writing a new Config

Recommended Posts

I was editing a ZDoom Config to include the new weapons, monsters, and ammo I created for a wad I'm working on. However, I encountered an error as follows:

Error 457 in LoadMapConfiguration: This key is already associated with an element of this collection
I get it every time I load the wad, or an wad or map using the new config. I'm not certain what the problem is now, as I couldn't find anything that would cause problems (Such as duplicate DoomEdNums, etc.) I'm curious if anyone else may be able to find it?


Thanks in advance to anyone who helps.

Share this post

Link to post

I'm only guessing, but these seems to be in error ...

1407 = "Sound Sequence 7";
1408 = "Sound Sequence 8";
1409 = "Sound Sequence 9";
title = "Sound Sequence";
arg1 = "Sound Sequence Number";
14001 = "Ambient Sound 1";
14002 = "Ambient Sound 2";


14063 = "Ambient Sound 63";
14064 = "Ambient Sound 64";
title = "Ambient Sound";
arg1 = "Ambient Sound Number";

note sprite numbers 1411 and 14065. Normally, the title and args go at the beginning, not the end of the group.

EDIT - Just realised that the code is the same in ZDoom_Hexen.cfg file as well so this obviously is not the problem. I tried to delete this post but was denied. :(

Share this post

Link to post

Scanned over the config real quick, noticed only one thing. Line 2645: Not sure if the / is possible in this structure key name.

Share this post

Link to post

I removed the slash and still receive an error. However, I narrowed it down and found that something in the section "weapons" is causing it. Some speculations are that perhaps there is a problem with the replacement BFG and RL or perhaps a DoomEdNum is mistakenly the same as another. I'm going to test these now.

[EDIT] Fixed it. Apparently, some of my weapons had several DoomEdNums that were the same as several prop actors I made. I never originally gave the a DoomEdNum, so I decided to remove those props from the Config. Thanks for the help, though.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now