Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

XWE does not save location of certain types of moved lumps?

Recommended Posts

My wad has 5 maps, and originally they were all in the proper order in the list of lumps. Along the way I renamed Map01 to Map05 and vice versa. Some time later I noticed in XWE that Map01 had moved from near the top of the list of lumps (where I like all my map-related lumps to be) all the way down to the bottom. To move the relevant lumps back to near the top I selected them, cut them, moved to the top of the list, and pasted them there. After I close XWE and reopen it to look at the wad I see that the position is all the way back at the bottom. I have done this several times, and each time the same thing happens.

Now this is not a serious issue, and the wad is unaffected in any other way. However, I am a "neat freak" in many ways, and I want to see my map-related lumps together.

A couple of related notes:

    1. This only seems to happen with map-related lumps. I have moved (using CTRL-D and CTRL-U) other entries up and down as well as cut and pasted them, and they have stayed in place.
    2. I have not tried using CTRL-U to move the map-related lumps all the way to the top, as I have more than 2500 entries in the wad, and it seems a waste of time.
    3. I have tried saving the map-related lumps into a folder on my hard drive, then using the Load feature to insert them back at the right position. The main problem is that the map gets completely screwed up (but other entries don't seem to be obviously messed up), so I didn't bother with this method any further.
    4. I have only been trying the cut-and-paste maneuver with v1.16, as I've had other issues with the beta, and don't want to risk further problems. (Perhaps, as a theoretical exercise, I shall try this method on a copy of the wad using the beta.)

Share this post

Link to post

I could not reproduce this, cut/paste immediately modifies the WAD and the lump directory. If you have the time, please make a copy of your WAD, open it up with the latest, and cut/paste it.

However, I did find a related bug, which might be the cause of all the warning messages: after cut, XWE modifies the WAD file, but I forgot to put in the call to get the updated file date. (Since at this point we DO know that the file is modified.) So for ANY operation after the CUT you would get the warning. This is now fixed, grab the latest from the usual place.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this