Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Help needed with RTC-3057 hub 1

Recommended Posts

Hello everyone!

First of all let me say sorry if this question was already posted and answered a few times. I searched the forums before registering but found nothing on the issue. I also looked into the txt file, tried gzdoom instead of zdoom, gotten the new fresh versions, went into the console commands, searched google, but didn't manage to solve the problem so pretty much this forum is my only help left :p

So. When I start zdoom with the wad, always an error message pops up that says:
Tried to register class 'Pistol' more than once.
Then the loading stops. :(

Damn, I'm really desperate to play this wad :) Any help is very very appreciated.


Share this post

Link to post

sounds like either a DECORATE or DEHACKED error.

Looks like the person who made the wad tried to make a new pistol but failed...you could try to get rid of the new pistol entry I guess...but I havent played that wad yet so I dont know where it is...

Share this post

Link to post

The WAD has a minor incompatibility with newer ZDooms.
You have 2 choices:

1) play with ZDoom 2.0.63a (if you can find it)
2) fix the problem. For that get a WAD editor like XWE or SlumpEd, find a lump called DECORATE and search for the word 'pistol' in it. Now rename this single word into pistol1 and it will work properly.

Share this post

Link to post

Thank you very much for your fast responses!

I tried to run the WAD with zdoom 2.0.63a and it works perfectly. :)

But I'll try to fix the WAD myself with Graf's instructions, so I can play it with gzdoom, the opengl rendering is beautiful.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now