Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Memory could not be read...

Recommended Posts


I'm new here and pretty new to Doom modding. I've searched around but haven't found a solution to this so here goes.

I'm using Doom Builder and I've made a map, which, according to the "Check for errors" function, has no issues. However, when I load it up in-game (Doom 95) it crashes as soon as I look slightly to the left of the start, I'm guessing because of a bug with a certain wall or something in that general direction.

The error I get is:

"The instruction at 0042ff69 referenced memory at 01b21000
The memory could not be read from

Click on OK to terminate the application"

Can anyone help me identify the problem?

- Danjb

Share this post

Link to post

sounds like an Access Violation.

This can be caused by many things.

1. Bad/corrupted memory bank in your RAM
2. Virus
3. Corrupted lumps in the PWAD
4. Corrupted game files for Doom 95 (why would you use that anyway?)
5. Something in your wad causing the level cache to be read wrong and crash out.

My suggestion is to test this with several wads to see if any place gives you that error. If not, try rebuilding your wad with a different node builder.

If you do get the error in other wads, try reinstalling or just plain updating to a different port (like ZDoom for instance).

To get more specifics, click the Details button on the AV dialog and paste that info here.

Share this post

Link to post

Thanks for the quick reply.

I very much doubt it's any of the first 4 ... So I guess it must be something to do with my level? I think I've had it before but fixed it again as the cause wasn't so hard to find.

What's wrong with Doom95? Easy interface, get straight into any level, demo recording and deathmatching :D

There wasn't a details button on the error message.

What did you mean by try testing it with different wads?
I'll try a different node builder.

I've uploaded the file, if you get a chance please can you take a look at it? It's E1M3 that doesn't work.

- Danjb

Share this post

Link to post

I would say you've hit some sort of limit in Doom95 (especially after looking at the ammount of two sided linedefs in the start room of the level), since after running the map in Doom95 and it crashing, I tried running it in a couple of source ports, Doomsday and ZDoom, and the map ran absolutely fine.

Doomsday and Zdoom are two of many many fan made engines for Doom that add dozens (and probably hundreds) of new features to Doom and support much bigger and detailed maps than the offical Dos and Doom95 engines. Though you need a Doom/Heretic/HeXen or Strife Iwad to use any fan made engine (as you do with the offical engines).


Though some of the versions linked to are not the most up to date versions (i.e the version of Doomsday listed is ancient). Hence I recommend visting the homepages of any you find interesting (the "link" link :p) to check for more up to date versions.

Share this post

Link to post

Are there any alternatives to getting a new port?
Any way to dodge the limit?

EDIT: I've fixed the problem by making a few linedefs one-sided and spacing them out a bit, etc. I may get a new port anyway, however.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now