Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Khaoscythe

Lag problems w/ Doom on VIsta:

Recommended Posts

Once in a while while playing (G)ZDoom (rarely happens with PRBoom) the game tends to lag and or processes random inputs from time to time (I wind up turning or running forward for absolutely no reason without inputting the command...someone plz tell me how to remedy this conflict?

Share this post


Link to post

I dont really know the answer to this problem but I've experienced similar kind of problems with zdoom on windows xp. Sometimes the whole game freezes for a split second before hearing a sound for the first time, for example when the plasma gun is fired the game locks up before the first shot and then fires all the shots at once that were supposed to be fired during the delay time. Sometimes it might be some enemy's awakening sound and when shot with a ssg the firing sort of freezes and the ssg automatically fires shots until the fire key is pressed again. I suspect this has something to do with antivirus programs that try to look for the wav files in the wad or something. I have nothing else in mind. If anyone knows what might be the cause behind this the answer would be much appreciated.


My laptop specs are: Intel Centrino T7200 2Ghz Dual-Core, 2GB RAM, 160GB HD and Windows XP.

Share this post


Link to post

If we're going to be talking about problems with ZDoom on Vista, the one one I have or seem to have thanks to the OS is that MIDI music will seem to lag while playing and/or moving but goes back to playing normally when accessing the menus or standing still. Don't know if it's an issue with the OS or the hardware though. I'm guessing the latter, but whatever.

Share this post


Link to post

I remember having this problem, then I set ZDoom to run in Windows 98 compatibility mode (right click the EXE or shortcut and go to properties, compabitility tab). Then it stopped.

Share this post


Link to post

Weird thing is this is the first time this has happened for me. I've run ZDoom on XP (both 32 and 64 bit versions) and it never happened then. Again I'm thinking it's more likely a hardware issue; I'm using on-board sound with HD drivers. Maybe I'll have better luck getting an actual sound card.

Share this post


Link to post

Must be your hardware. I also have vista, and the only problem I have (running zdoom/gzdoom/skulltag) is an occasional and severe drop in framerate for a minute or two after playing for a certain amount of time.

Share this post


Link to post
Jim Rainer said:

Must be your hardware. I also have vista, and the only problem I have (running zdoom/gzdoom/skulltag) is an occasional and severe drop in framerate for a minute or two after playing for a certain amount of time.


its the operating system not the hardware

Share this post


Link to post

I've also run ZDoom on Vista before and never had this problem...and it was the same version I'm running now too. Of course, I've been downloading a lot of shit lately while playing, maybe that's it. Heh.

Share this post


Link to post
KarlBhalai said:

its the operating system not the hardware



No, it's most likely some inappropriate settings (e.g. energy savings options.)

Share this post


Link to post
KarlBhalai said:

its the operating system not the hardware

Not exactly, I had the same problems on my parents' XP and my old 98, so it might actually be the software as well as the hardware.

Share this post


Link to post
Nebula-Kristian said:

I dont really know the answer to this problem but I've experienced similar kind of problems with zdoom on windows xp. Sometimes the whole game freezes for a split second before hearing a sound for the first time, for example when the plasma gun is fired the game locks up before the first shot and then fires all the shots at once that were supposed to be fired during the delay time. Sometimes it might be some enemy's awakening sound and when shot with a ssg the firing sort of freezes and the ssg automatically fires shots until the fire key is pressed again.

Hah, that's exactly what I experience on Win98 when running vanilla. I'm pretty sure sound drivers are to blame (or maybe some sound settings). None of this happens with Boom or any other ports.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×