Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Chex Warrior

GZDoom Vertical Tear

Recommended Posts

I've had this problem for a while... Whenever I play GZDoom, I get awful vertical tear, I read around and turned on vertical sync, in addition I capped the FPS. This does help some, but the tear is still quite bad... I've tried several random things, mostly stuff I picked up from old forum posts but it doesn't seem to help. Anyone have any ideas?

Here are some of my specs:

I have a Vostro 1000 laptop.

OS: Vista Home Basic
RAM: 1 gig
Processor: AMD Athlon 64 x2 Dual Core
Graphics Card: ATI Radeon Xpress 1150 (Catalyst 8.4)

Share this post


Link to post

Try adjusting your monitor's refresh rate. I think vertical sync is supposed to alleviate this problem by limiting the framerate to the refresh rate of your monitor or some non-sense, but I experienced the same exact problem with Half-Life on an old video card a few years back despite setting vsync to on.

Messing with the refresh rate solved the problem. Keep vertical sync on though.

Share this post


Link to post

Hmm, well I update my drivers every month but I'll look again. As for the monitor refresh rate... I don't think it can go above 60 Hz.

Thanks for the replies though.

Share this post


Link to post

Have you compared your monitors refresh rate to the framerate in GZDoom?

I'm not sure where you can view the refresh rate setting in Vista, however I do know in Win9x/NT/2000/XP it's "Display Properties=>Settings Tab=>Advanced button=>Monitor tab", then look under Monitor settings. Like I said, don't know if that's where it is in Vista though.

Anyway, in GZDoom, you can bring down the console and type "vid_fps 1" (without the quotes) and this will give you your framerate. Then you can just go into a simple room and see if it goes above your monitors refresh rate or not.

If it does, then obviously GZDoom isn't properly seeing your monitors refresh rate, as to why I would have no idea though.

If they do match up, then there is either something wrong with your drivers or the graphics card itself.

Share this post


Link to post

Nuxius, I did what you suggested and the framerate is indeed lower than my monitors.

However, after disabling Catalyst A.I. and forcing my applications to wait for the vertical refresh (a Catalyst option), the vertical tear has stopped!
But, now GZDoom seems to run slowly -not just when in a big area or exclusively bad framerate... It just seems choppy. I'm starting to think it may just be my hardware.

So, I guess I'll just start using ZDoom again, which when it comes right down to it still allows me to play Doom without too many problems.

Anyway, I appreciate the help.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×