Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
pcorf

Problem with scripting

Recommended Posts

I'm having problems trying to compile scripts in Doombuilder. No matter what I try I keep on getting this message. I've checked everything and there are no mistakes. Please help me, how do I fix it, or is this unfixable?

Line 24 in file "script.acs" ...
script.acs:24: Missing required argument.
> hudmessage (s: "Player:
> ^

The ACS compiler did not compile your script.

Share this post


Link to post
esselfortium said:

Have you tried removing the space, to make it hudmessage(s: "Player: ?


Still dosen't work. Looks like the DB or ACC (1.37) hates the script and I will have to re write it from scratch. Other scripts work fine but this just happens randomly. Looks like its impossible to fix.

Share this post


Link to post

What is the script before the line the error points out? The error tells me you didn't put enough arguments in your last statement.

Share this post


Link to post

It is possible that the script you're using requires more arguments than you included. Even if you want to use a default value for a parameter, I believe you still have to define the defalut unless the only argumant you're changing is the first. Have to checked to see if there are any obscure arguments your function needs?

Share this post


Link to post

I re wrote the script from scratch and it now works fine. Yay!. I'm working on a Jokewad exclusive to Paul's Doom Page named the Adventures of Zbub. It will only avaliable from my page and not be uploaded to the archives.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×