Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Fenriswolf

How to create slantwise sectors / add new Slots

Recommended Posts

Hello,
Again two Questions from me:

1. How can I create Slantwise Sectors in DoomBuilder? (Such as Roofs and Hills). I play with Skulltag, which supports ZDoom, so this should be no problem but i simply dont know how to do it...

2. How can I add new Slots for things such as statues, mushrooms, trees, etc?

Share this post


Link to post
Fenriswolf said:

Hello,
Again two Questions from me:

1. How can I create Slantwise Sectors in DoomBuilder? (Such as Roofs and Hills). I play with Skulltag, which supports ZDoom, so this should be no problem but i simply dont know how to do it...

With the power of the ZDoom Wiki. Note that in Doom Builder's 3D view, slopes won't be sloped. To check whether they worked correctly, you'll have to test the level in the game itself.

Fenriswolf said:

2. How can I add new Slots for things such as statues, mushrooms, trees, etc?

With the power of the ZDoom Wiki. What you call slot is the DoomEdNum of the item, so you'll have to do actor declarations like "Actor Mushroom 9999" to create a "Mushroom" actor with the 9999 "slot". If you have a DECORATE lump in your wad, DoomBuilder will automatically recognize it and display the new elements in the Decorate category.

Share this post


Link to post

The Second Thing:

I read the ZDoom articles and tried to create the DECORATE-Script.
It looks like this:


actor TREE 9992
{
height 60
radius 20
+SOLID
states
{
Spawn:
HAW6 A 10
HAW6 B 10 bright
HAW6 C 10
loop
}
}


Then I made the Tree-Graphic an imported it as a sprite in my wad file, I did the same with the Decorate.txt.
But I dont know how to order the script to use the tree sprite I have in my wad. I read this has something to do with the spritename, but i dont know exactly what to change. The attributes of the sprite are:

Entry Name: TREE
type: 31
position: 12 (<=== Dont know what that means, but if i change it, the tree graphic disappears)

In Doom Builder the new Thing does appear and I placed a few of them on my map but there was no graphic and when i tested the map there appered the error message:

THINGS NOT FOUND IN E1M1


What to do?

Share this post


Link to post
Gez said:

Note that in Doom Builder's 3D view, slopes won't be sloped.

Gee, I hope Doom Builder 2 sees slopes. :P


With the power of the ZDoom Wiki. What you call slot is the DoomEdNum of the item, so you'll have to do actor declarations like "Actor Mushroom 9999" to create a "Mushroom" actor with the 9999 "slot". If you have a DECORATE lump in your wad, DoomBuilder will automatically recognize it and display the new elements in the Decorate category.

ZDoom is not the only port which allows new things, by the way. As for adding the things in DOOM BUILDER, simply edit the game's CFG file from the doom builder folder.

Share this post


Link to post

Yeah I tried this and edited the file you mentioned, yeah It worked the tree appered with grafic in the doom builder (but without transparency (?!)) but when i try to run the map there doesnt appear any trees....

What should i do different with the sprite/script?

Share this post


Link to post
Fenriswolf said:

Then I made the Tree-Graphic an imported it as a sprite in my wad file, I did the same with the Decorate.txt.
But I dont know how to order the script to use the tree sprite I have in my wad. I read this has something to do with the spritename, but i dont know exactly what to change. The attributes of the sprite are:

Entry Name: TREE
type: 31
position: 12 (<=== Dont know what that means, but if i change it, the tree graphic disappears)

Meh, I don't know either.

As far as a I know, a sprite has a name, a X offset and a Y offset. If the sprite's name is just HAW6, rename it to something like TREEA0.

Then your DECORATE will look like this:

actor Tree 9992
{
   height 60
   radius 20
   +SOLID
   states
   {
      Spawn:
         HAW6 A -1
         loop
   }
}
Now, a bit of explanation for this "states" business. It tells the engine which sprite to show in which condition. A simple decoration will normally always stay in the Spawn state, which is the state all objects are when they are spawned (including at level start).

A sprite has a name with four letters (here, TREE), followed by a frame identifier (here, A), and a rotation identifier (0 here for "no rotation", otherwise a number between 1 and 8 for the various angles, 1 being front rotation and 5 being back). Rotations are usually only for monsters and players, decoration items like trees having none because it's simpler this way.

The code you have shown required three sprites: HAW6A0, HAW6B0, HAW6C0.

HAW6 A tells the game to get display a HAW6A sprite, so HAW6A0 will be displayed. If you have rotations, it'll display HAW6A1 if you look at the front of the tree, HAW6A3 on the side, and so on.

printz said:

Gee, I hope Doom Builder 2 sees slopes. :P

It was just to tell the OP not to panic if the slopes do not appear when he checks his level in 3D view. He mentioned using Doom Builder.

printz said:

ZDoom is not the only port which allows new things, by the way.

Yeah, but the OP specifically mentioned making a level for Skulltag, so it's the ZDoom method which is relevant.

Fenriswolf said:

Yeah I tried this and edited the file you mentioned, yeah It worked the tree appered with grafic in the doom builder (but without transparency (?!)) but when i try to run the map there doesnt appear any trees....


I'm guessing your sprite hasn't been converted to Doom graphics correctly. As a result, it lacks its offset and the transparent color hasn't been converted to actual transparency.

XWE and SlumpEd can set a sprite's offset and convert it. The X offset should be about half the image's width, and the Y offset should be about the image's height. Otherwise, with the default offset of 0, 0, the sprite will be shown, but underground... So you won't see it.

If your sprite is in the PNG format, remember that cyan is not actually a "transparent color" in Doom, despite popular belief. For a cyan color in a PNG to become transparent in Doom, it has to be made transparent in the PNG itself first!

If your sprite is BMP, BMP has no transparency support at all and ZDoom/GZDoom/Skulltag doesn't support them anyway so they'll be unable to display the sprite.

Share this post


Link to post

Ah, thank you very much that looks like good help!
But now a bnew problem came:

When I try to open my wad with doombuilder, there is this selection window where I select the map i want to open. But instead of E1M1, the maps name is now "DECORATE", which is very stupid. When I try to edit this, there comes a message like: Theres already a map with this name.
And when I try to test the map there still comes this THINGS NOT FOUND error message...


EDIT: Made another wad, this time there was not this Mapname bug, and were able to open the map but instead of the trees, little "!" stood in the forest...

EDIT2: Trees are in the map, I think I got it! Thank you very much!

Share this post


Link to post

These "!"s are missing things. You should check your decorate script for Thing ID. Thing ID in Decorate script is after class type in the header of actor. Header looks like this:

actor ThingName : ThingClass ThingID
Just use the numbers in ThingID and paste them into textbox(numberbox?) called "Thing ID".

EDIT:He fixed it by time i posted it.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×