Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Kyka

large wad Won't rebuild with the nodebuilders

Recommended Posts

Hiya everyone.

Just a quick question. I have a map (nearly finished) and at this point it will let the nodebuilder rebuild so that I can save the level, go into 3D mode etc. But it is at a point where if I add even one or two more sectors, then the nodebuilders (all three of them) do not rebuild the nodes. There are three sectors not closed on the map and many missing textures (all intentional... deep water, see through walls etc)but these have never presented a problem before today, and I have been working on this level for weeks now.

The stats for the level are as follows.

25362 vertices
29934 linedefs
51703 sidedefs
2832 sectors

From what I have read, I would not have thought this would be beyond reasonable for this to rebuild.

My question is this: is there a simple fix to this, to enlarge what the nodebuilders are able to work with easily?

Any thoughts appreciated.

P.S. I notice Essel has a thread that may or may not be asking the same thing as I am.

Thanks guys

Share this post


Link to post

More than likely, you've reached the blockmap limit.

Try using ZenNode with DB's standard options, but add "-bc" (without the quotes). This will tell ZenNode to compress the blockmap.

Let me know if this works.

Share this post


Link to post

Heya Nuxius. Thanks for the reply.

Yeah I tried what you said.

The one thing is that Zennode doesn't seem to work for me at all. I have tried it on a number of my maps over time and the only one that seems to work for me is the default one (zdbsp.exe)

So I tried adding the -bc (You add this in the parameters cmd line in the nodebuilders tab in the config menu yeah?... where it has written "-R "%F" -o"%T"" already typed there. I am a bit of a techno-noob so just checking)

I added the -bc and it didn't seem to make any difference as to how many lines, vertices etc that the nodebuilder would build.

Is there any reason that you specified Zennode? or should the "-bc" work just as well with zdbsp.exe..?

Share this post


Link to post

Blockmap compression is a ZenNode only feature, afaik.

You can add "-b" to tell ZDBSP to not build a blockmap, however, you will greatly limit the ports your map will work on if you do this.

Try it anyway, just to see if it is indeed the blockmap that is causing your issues.

Share this post


Link to post

Heya Nux....

Yeah I tried the -b command, and it didn't seem to solve the problem. Thanks for the info anyway. I now know what a blockmap is at any rate..!! Am gonna go reinstall Doombuilder, see if that fixes anything. I don't know that it will, but it is worth a shot eh..

Share this post


Link to post

Have you tried building the nodes outside of DB to see if that works?

If it does, then you at least know it's not something in your map.

If this is the case, then you can work around it by temporarily splitting the map into two maps (this way you can use 3D mode) until you finish working on it, then combine them and build the nodes outside of DB.

You could also try using the "-z" parameter in ZDBSP to tell it to compress the nodes, but I seriously doubt that would help, as you are not at the limit of 65535 sidedefs yet.


EDIT: Thinking about it for a bit, I wonder if you've passed Doom's segs limit (I believe it's 65535 as well). If that's the case, then using the "-z" parameter in ZDBSP will fix this. Try it and see if it works. If it does, then you probably just passed the segs limit. Doing this will allow you to carry on with your map.

Share this post


Link to post

The standard Doom SEG limit is 32767, which has been exceeded by quite a large margin. Kyka will need a port with an expanded SEG limit of 65535 to play this map. Such ports include Zdoom and the most recent versions of Eternity and PrBoom. Trying the "-z" parameter will probably solve your problem with the nodebuilder.

Share this post


Link to post

Ok... I'm going to go try that out. Is there any downside to compressing the nodes with the -z command? Ultimately I want my maps to be as reasonably compatible with as many ports as possible. Does the -z command make a map less compatible with different ports or any other changes that I should know? (though from what I gather by the size of my map, I may have limited myself in that regard anyway.)

Damn you guys know a lot. Thanks for your thoughts.

Share this post


Link to post
Kyka said:

Ultimately I want my maps to be as reasonably compatible with as many ports as possible.

The fact that there are over 65535 SEGs means it will not be Boom-compatible (the map will crash). AFAIK, This map will only work on Zdoom-like ports because they can use compressed nodes, which yield no SEG limit. As has been said, try using the -z parameter and the map should be playable on Zdoom.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
×