Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

Node lines appearing on maps

Recommended Posts

I dont know if there is a proper name for this effect, shown here and here, but I am wondering how best to fix the problem. It only ever seems to happen in areas where there are a lot of vertices. I have tried obvious things like reducing the number of vertices within the general area, and simply moving the linedefs around to force the vertices to restitch themselves, and I am just wondering:

a)To know more about what is actually happening here, and;

b)to see any possible solutions to the problem.

Thanks people. :)

Share this post

Link to post

This is caused by precision issues with the vertices. When nodes are being built some lines are split and new vertices habe to be added by the node builder. But the standard node format's precision is insufficient so the added vertices don't lie exactly on the line that is being split. Some source ports attempt to correct these precision errors by realigning the vertices but even that is often not enough to get an error free display.

What you can do depends on the port you are mapping for.

If you are mapping for ZDoom the best idea is to use ZDBSP with the '-z' option. This way you will get full precision for the vertices required for the BSP.

If this needs to work with other ports as well you may have to try different node builders to see if this makes any difference.

Share this post

Link to post

Last question in this regard. Is there any actual mapping do's and dont's that can help lower the incidence of this problem? I gather a simple answer is "Don't use lots of circular sectors" etc.

I am hoping to have these maps playable across a number of ports, so I am trying to avoid the "-z" option, tho perhaps that is being overly ambitious.

Damn you people know A Lot (capitals intentional)about how this game works.

Thanks heaps Graf. Now I understand a whole lot better.

Share this post

Link to post

Those are slime trails. Even the very first map of Doom had several (most notably the one in the nukage room from where its name was derived). The easiest way to prevent these are to avoid many odd-angled linedefs. The more you have, the bigger your chances of getting a slime trail. If you stick to making objects manually (and not relying on automated tools in your editor) and put linedefs at angles of multiples of 15 degrees, then usually you won't have many problems.

If a slime trail does pop up though, the easiest way to fix it is to adjust your nodebuilder or just simply moving the offending vertex a couple of units.

Share this post

Link to post

OK... Time for another noob question. When I add -z to the command line in the nodebuilder tab, my nodebuilder refuses to rebuild the nodes, but it still launches the map, and the weird thing is this: Now all the slime trails are gone and the map runs fine. Ok, I have only tested it under ZDoom, but I don't understand why the map runs fine without rebuilding the nodes at all. No slime trails, no problems, no nothing.

I can't help but think that there will be unforeseen consequences in allowing things to continue like this.

P.S. Thanks Earthquake. For what its worth, I think you should be promoted to 9.6

Share this post

Link to post

ZDoom has an internal node builder which is essentially ZDBSP with -z forced to on.

Regarding '-z', you can't do that from within Doombuilder. For some reason Doombuilder refuses to consider such a map valid. You will have to do an external node build from the command line.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this