Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
ellmo

Can't find my erroneus flatnames

Recommended Posts

I don't know what I did, but I get flat errors while trying to run the map in PrBoom. GZDoom can run, ignoring the bad flats, but the flat warning entries are visible in the console.
I can't find those bad sectors in DoomBuilder, since their names contain some fucked up characters.

Does anybody have an idea how to find the textures? Any editor that has anything to find bad flats?

Share this post


Link to post

Okay, I'm gonna reply to myself (it can be useful for anyone encountering the same problem).

Great tip from my pal Alter: Run your erroneus map with PrBoom (it will crash), and read stdout.txt file in your PrBoom direcotry. You can get your bad flatnames from there in simple text. Copy paste them to Doom Builder (or whatever you use) and fix the problem.

Share this post


Link to post

Yadex has a "Check Texture names" feature which will find bad flat names too (I just tried it).

Yadex however is only a Linux program, but perhaps the editor it was based on (DEU 5.21) or another editor based on it also has that feature.

Share this post


Link to post

If GZdoom was spitting the names out at the console, you could also have have dumped that to a logfile by starting with

gzdoom -file myfile.wad +logfile log.txt

I know that DeePsea can check for invalid texture/flat names. Can DB not do something similar?

Share this post


Link to post

DB can check for invalid textures as well.
Go on Tools --> Find map errors.

Check the tests you want to do, and voila!!! Piece of cake!

Share this post


Link to post

Oh come on guys. I would not post this if DB showed those flats in error check :] It didn't, but at the same time (when I copy-pasted their names into the find tool) showed them as invalid.

I'm pretty sure DB always found any invalid texture I had. But those flats were a mystery to me.

Enjay said:

gzdoom -file myfile.wad +logfile log.txt

Ah, that's very useful too. Thanks.

Da Spadger said:

Sorry to go off-topic Ellmo, but I sent you a PM a while ago, and I still haven't got an answer. D:

I'm very sorry. That's just rude of me. I shall answer at once!

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
×