Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Subatomic

Suddenly broken vanilla compatibility... why?

Recommended Posts

I've been wracking my brain on this for hours now and cannot come up with a solution. The map I'm currently working on has been perfectly compatible with vanilla Doom 2 (tested in Chocolate Doom) ever since I started making it. Until today. For no reason at all, I suddenly can't run the map in Chocolate Doom. When I load it, it immediately crashes. In Doom Builder, there are no errors. In DeePsea, there are a couple errors, but they don't seem related to the current problem. I've checked to see if maybe I had left a camera thing entity in, but there isn't.

This is the only error given when Chocolate Doom crashes:

W_Win32_OpenFile: Unable to MapViewOfFile() for doom2.wad
W_Win32_OpenFile: Unable to MapViewOfFile() for Exp.wad
Any idea what this means? If someone would be willing to take a look at my map, please send me a private message and I'll send a copy to you. I've tried everything I can possibly think of... maybe someone with more experience can find the problem.

EDIT:
In case they may actually be relevant, here are the DeePsea errors:
SD 00047 SideDef 47, Xoffset -64 (maxoffset set in F5 options)       
SD 00049 SideDef 49, Xoffset -96 (maxoffset set in F5 options)
SD 00061 SideDef 61, Yoffset -16 (maxoffset set in F5 options)
SD 00250 SideDef 250, Xoffset 16 (maxoffset set in F5 options)
SD 00765 SideDef 765, Xoffset 28 (maxoffset set in F5 options)
-- 00000 There are no exits in this level
L  00510 LineDef 510 WR*Teleport (sector tag 13)
L  00510 2 Sectors have same Teleport Tag?
L  00511 LineDef 511 WR*Teleport (sector tag 13)
L  00511 2 Sectors have same Teleport Tag?
L  00512 LineDef 512 WR*Teleport (sector tag 13)
L  00512 2 Sectors have same Teleport Tag?
L  00513 LineDef 513 WR*Teleport (sector tag 13)
L  00513 2 Sectors have same Teleport Tag?

Share this post


Link to post

Have you messed around with the lump structure? Use XWE or DeepSea's lump editor recently? Rare circumstances can lead to a corrupted that displays no errors in an editor. Have you tried rebuilding the nodes?

Also, can you give us some specs on the map? Hitting any limits? Does it work in other ports? If ran in ZDoom does it display a warning in the console? Oh and make sure Chocolate Doom isn't having the problem. Fraggle can probably tell you more about the error message.

Edit: Actually, now that I noticed, it says doom2.wad couldn't be loaded. I stress, make sure it's not a problem with Chocolate Doom. Maybe try restarting your computer.

Share this post


Link to post

I have actually used XWE recently. I was trying to add music, but it didn't work, so I took it out. (maybe that screwed it up?) Also, when I run doom2.wad in Chocolate Doom by itself, it works. When I try to use the commandline -file Exp.wad, that's when it crashes. And by the way, the map works fine in Doomsday, it says 0 serious and 0 minor warnings.

If it may have been XWE that broke it, is it possible to fix?

EDIT: Well, this is strange... just as randomly that it broke, it has now somehow magically fixed itself. It's working in Chocolate Doom again. Guess I'll just chalk this one up to a computer fluke. Thanks for the tip about XWE though, I'll avoid it in the future (or at least until I know better how to properly use it).

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
×