Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Phil1984

Can not increase screen size in Doom/Chocolate Doom

Recommended Posts

I'm not sure if this belongs here or in the source-port section so Mods, move it if need be.

It's a very weird problem and I'm not sure if anyone would be able to help me but here it goes. It seems to be impossible to increase the screen size (I don't mean the resoulution, but the actual size of the window that Doom is being played in) in both the original Doom (Played inside dosbox) and Chocolate Doom. While the "-" key certainly makes the playing window smaller, it is impossible to increase the window back again using the "+" button and the only way to make the window bigger again is to go into the default.cfg file and increase the screenBlocks back up to 11.

What makes it weirder is that it only affects Doom/Choclate Doom as far as I can tell. It works fine in Prboom, I have no difficulty typing '=/+
' in a web browser or in Word. When I use the mskey program which lets you know which button you are pressing down on the keyboard it correctly indicates that I am pressing down the +/= button. I am running a Vista Laptop hooked up to an external monitor/keyboard/mouse and it doesn't matter if I'm using the external keyboard or if I unplug it and use the laptops this problem still occurs. Does anyone have any ideas what is wrong?

Share this post


Link to post

I had something similar happen to me with... I forget what key. Anyway I used the Choco-Setup to set my controls but this one key didn't work in game so I deleted the key reference from the config and used doom's setup to rebind the key and it worked fine after that. Maybe doing that will help you I hope.

Share this post


Link to post

Thanks for your suggestion :) The problem is that changing the screen size is hardwired into the actual program. It is impossible to change the key that performs this function...

Share this post


Link to post

A rather odd bug. I should be able to help you because I'm the author of Chocolate Doom :-) Some questions:

  • What OS are you running?
  • If you run it windowed instead of fullscreen, does it make any difference?
  • Go to the save game menu and start entering a save game description. Is it possible to enter a '=' and a '+' in the box?
  • If you change the "native keyboard mapping" option (in keyboard settings) does it make any difference?

Share this post


Link to post

Thanks for the reply Fraggle. To be honest I doubt its a Chocolate Doom bug, originally I thought it was but I thought I'ld see if the problem occurred in Doom 1.9 and sure enough it does. So it may very well be a problem with my keyboard driver (though I don't see how as the key works fine in other programs)

To answer your questions:

OS - Vista, unfortunatley

It does not seem to matter if I run it in windowed or fullscreen mode I can not use the + key

Good suggestion. No,I can not enter a '=' or a '+' on the savegame screen! I can enter a '+' from the numerical keypad though. If I press '-' on the numerical keypad the screen size does decrease but once again a '+' on the numerical keypad does nothing. I can't remember how the original doom operated though so this might have been normal behaviour?

Yeah I fiddled with the native keyboard mapping option but it makes no difference.

Share this post


Link to post

Yeah, good thinking with the keyboard layout. It was set to English (Australia) U.S but I thought maybe that was causing the problems so I changed it to English (United States) - US however that did not change a thing. My external keyboard does not have an F-Lock thingy but my laptop keyboard does. The problem occurs on either keyboard...

Share this post


Link to post

Phil1984 said:
No,I can not enter a '=' or a '+' on the savegame screen! I can enter a '+' from the numerical keypad though. If I press '-' on the numerical keypad the screen size does decrease but once again a '+' on the numerical keypad does nothing. I can't remember how the original doom operated though so this might have been normal behaviour?

No, the + and = signs can be typed in to the save game field in Doom. Presumably you should have the same problem in the automap or when using the chat function. Can you type these characters into the command prompt or into the DOSBox console?

Share this post


Link to post

Hey Myk, its very odd indeed, I have no problam typing the "="
ken into the command prompt however it appears that I am unable to type that same key into the dosbox prompt......

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
×