Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
YukiRaven

Odd file locking problem

Recommended Posts

I've just done a fresh install of Doom Builder and am having an odd file locking issue that didn't exist before. Whenever I go to build the nodes from within Doom Builder, regardless of the node builder I use (I've tried glbsp 2.24, zdbsp 1.8, and ZenNode 1.2.1), it fails with the message "The nodebuilder did not build the required structures. Please ensure you do not have any errors in your map!"

Running the nodesbuilder from the command line with the level open in Doom Builder also results in the same error. However, if I close the level in Doom Builder, the nodes build fine from the command line.

I've restarted my system to make sure there weren't any other odd processes that might have been holding onto the file.

Any ideas?

Share this post


Link to post

nvm, I figured out that if I remover the quotation marks around the %F and %T variables and use glbsp, things magically work fine. zdbsp still doesn't, so if anyone has an idea for that, it'd still be appreciated :)

Share this post


Link to post

The only time I ever see that message is when I am working on a really big map and either:

1)The map is too big for the nodebuilder to rebuild or

2)The map is above a certain size and has unused sectors in it. So I save the map, (getting the error message that you spoke of) and then reopen the saved map, and I get the message "1 (or however many there are) unused sectors have been removed.) Then I can use 3D mode or save normally.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×