Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

Vanilla Doom "cannot open" wad

Recommended Posts

For some reason, whenever I make a single level wad and try to open it in vanilla, I get the message "cannot open [wadname].wad" before the "This version of Doom has been modified" message. The full episode 1 replacement I made works, but when I tried taking out all of the maps but one, it wouldn't work. I even tried putting empty map markers for the other levels, but no luck.

Share this post

Link to post

That error should only occur if Doom can't create the file handle. Is the WAD open in another program?

This is the code that produces the error:

    if ( (handle = fopen (filename,"rb")) == NULL)
	printf (" couldn't open %s\n",filename);

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this