Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
solarsnowfall

UDMF Texture Paste in Visual Mode Error

Recommended Posts

I've run into this error 4 times now on my first map project in DB2. It seems to happen quite randomly, but always happens during a texture paste in Visual Mode. I get an error and am given the option to continue or quit. Not wanting to lose all my progress, I select continue and save. Upon saving, I'm told that nodes were not built due to an error (which wasn't there seconds ago). If I close the map and open it up again, nothing in the map is there. No lindefs, no verteces, no things, nothing.

So I open up the TEXTMAP lump to see what can be seen and I come across the last sector entry which always looks something like this.

sector
{
	heightfloor = 0;
	heightceiling = 192;
	texturefloor = "FLOOR0_1";
	textureceiling = "F_SKY1";
	lightlevel = 192;
	!virtual_sector = 0;
}
It always contains that last command, !virtual_sector = 0;. If I remove that command, I can open my level back up in DB2 and continue editing.

The reason that this is so annoying is that once I trigger this error, I can't do much of anything without generating the quit/continue error message. I pretty much have to stop editing, close the map, and fix the TEXTMAP lump before I can continue editing the map.

Vista 64
Intel E6750
4.00 GM Memory
nVidia 8800 GTX

Share this post


Link to post

Oh yea, almost forgot. After removing the TEXTMAP entry and making my level editable again, there is always at least one sector that gets screwed up and all two-sided linedefs associated become 2 seperate lines layed on top of eachother, as though the geometry wasn't merged properly. And no, I've not turned off Merge Geometry.

Share this post


Link to post

Interesting. This should not be possible, the !virtual_sector should never even get there. Can you figure out how to reproduce this? This must have something to do with copy/paste of geometry (in classic modes), because that is where !virtual_sector is used.

Share this post


Link to post

I just produced it twice after pressing Ctrl+V in Visual Mode after pasting some geometry in Sectors Mode. The first time I "pasted" then mouse clicked to paste after realizing that Ctrl+V had not achieved the desired effect. The second time was upon exiting Visual Mode after pressing Ctrl+V. It seems that even though texture pasting is bound to a mouse button I still have a habbit of pressing the Ctrl+V from time to time.

Share this post


Link to post

I think I found it and fixed it. Should be in the next version that I hope to release this weekend.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×