Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Eponasoft

Sector type 12 inconsistency

Recommended Posts

So I'm using odamex and vavoom to test a map I'm working on right now. Vavoom is obviously much more impressive on the lighting aspect, but how it handles sector type 12 (1hz sync flash) is the inverse of how odamex handles it. Odamex starts dark and flashes light, vavoom starts light and flashes dark. Which is the correct behavior?

Share this post


Link to post

I bet my money on Odamex being right. I just did some testing in Chocolate Doom (which is as close to vanilla Doom as possible) and came up with these results:

12: Slow flashing (1 Hz), long dark duration with short bright flashes.
13: Fast flashing (2 Hz), long dark duration with short bright flashes.

Which leads me to believe my descriptions in Doom Builder are the other way around. I'll have to fix that.

Share this post


Link to post

OK that makes sense. I know odamex is pretty accurate to the original so I would certainly trust it being the correct one. So Vavoom has it backwards...interesting.

Share this post


Link to post

Confirmed with testing.

Indeed, sector effect 12 is 1 sec flash and sector effect 13 is 0.5 sec flash.

I think this goes back to the doom unofficial specs 1.666 which states this ...

12 0c Light blink 0.5 second, synchronized
13 0d Light blink 1.0 second, synchronized

This is now confirmed as being in error.

..... good find .....

Share this post


Link to post

The current version of vavoom - 1.30 - is fine.

Also, sector effects 12 and 13 do not work in EDGE at all.

Share this post


Link to post

I did "version" in the console and it returned 1.27. This was the latest ported version to FreeBSD at the time. I don't know if it's been updated since then...I guess I could always try building the latest from source though.

EDIT: Or at least I will attempt to build it...cmake is such a turd of a builder...regular old gmake would have been much better. Oh well...

Share this post


Link to post
hawkwind said:

Also, sector effects 12 and 13 do not work in EDGE at all.

Hmmm testing..... both 12 and 13 work for me in EDGE 1.31. Please tell me how you tested it.

Share this post


Link to post

Ran the test wad - sectors blink correctly in Vavoom 1.30 and not at all in Edge 1.31.

WadAuthor's text descriptors for sector effects 12 & 13 are transposed.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×