Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
FireSeraphim

A question concerning MAPINFO

Recommended Posts

I am now making a new mod. but i have up against a problem. I want to use the episode definition command known as "noskillmenu" to disable the skills menu that appears when you start a new game. But I honestly confess to not knowing completly how to use episode definition. Could anyone enlighten me?

Share this post


Link to post

Well, I've not done this myself, but following the syntax described in the ZDoom Wiki on MAPINFO, it would look something like this:

MAPINFO:

clearepisodes
episode MAP01  // Specify starting map for this episode.
{
  name "My Episode"
  noskillmenu
}

map MAP01 "First Map In My Episode"
// Other map stuff.
I think the engine doesn't need to know what maps are in the episode, just what map to start with. The map definitions themselves will define which map is next in the sequence.

Share this post


Link to post

Now i got a new problem. when I go to thes this out it keeps on giving me this annoying message.
--------------------------------
Script error, "MAPINFO" line 3
bad syntax
--------------------------------

and this is what I got in my MAPINFO Data

--------------------------------
clearepisodes
episode MAP01
// Specify starting map for this episode.
{
name "Despair"
noskillmenu
}
map map01 "Jungle Base"
sky1 rsky1 0.0
music D_RUNNIN
next map02
cluster 1
par 250
evenlighting
cluster 1 // Sets up the cluster
clusterdef 1 //Defines the cluster settings
exittext "testing, testing.
123 testing good"

//Text that comes up when leaving cluster.
music D_READ_M //Normal Text music
flat RROCK04 //The flat that's in the background
-------------------------------

Now how can my MAPINFO data be wrong.

Share this post


Link to post

Actually, I might have misinterpretted the syntax myself. Seeing as MAPINFO usually doesn't use braces for blocks, try removing the braces I added.

Edit: nevermind, the example shown on the Wiki seems to use braces, so I was right about that.

It says line 3 is the problem line, so try getting rid of that comment.

Share this post


Link to post

I tried both suggestion just now and they don't seem to work. I am about to tear my hair out unless there is an anwser to this madness.

Share this post


Link to post

The old syntax is still supported of course. What's not supported is mixing both old and new in the same lump. Get rid of those braces.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
×