Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
aaglo

Wondering about animdef & animated switches

Recommended Posts

Hi!

I have this in my animdef-lump:
-----------------------
switch doom 5 swch1
on sound chainswitch
pic swch1 tics 6
pic swch2 tics 6
pic swch3 tics 6
pic swch4 tics 6
pic swch5 tics 6

off sound chainswitch
pic swch5 tics 6
pic swch4 tics 6
pic swch3 tics 6
pic swch2 tics 6
pic swch1 tics 6


switch doom 3 swrop1
on sound ropeswitch
pic swrop1 tics 8
pic swrop2 tics 8
pic swrop3 tics 8

off sound ropeswitch
pic swrop3 tics 8
pic swrop2 tics 8
pic swrop1 tics 8
--------------------

Now, The 3-pic ropeswitch works perfectly, but the 5-pic chainswitch does not.

First I have to admit, that I don't really understand why the animated switch has to have that word "doom" there. But it does have to be there - I tried without it or replaced it with hexen, the game would not run at all. And I just assumed that the "3" is the number of the pics (since the chainswitch did not work with "doom 3").

So, could anyone help me? The zdoom-wikisite does not give much on animdef animated switches...

Cheers,
aaglo

Share this post


Link to post

If you omit 'doom' and the following number it should work. That number does not specify the amount of frames. It's a game filter parameter.

In ZDoom the number is no longer used (it's a leftover from a feature that was removed due to pointlessness) but since you are not telling if you actually use ZDoom I'm not 100% sure if this may be the cause. In ZDaemon or older version the first switch cannot work because 1,2 and 3 are the only valid values for this number parameter.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×