Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

Trouble with Textures

Recommended Posts

This is a weird one.

I've got a few custom textures in my wad file that I don't much wish to part with (slime/waterfall, straight black wall, animated stars, glass, etc).

The problem is, if I use a custom texture lump (rather than none at all), a lot of the textures on my maps disappear. Upon closer inspection, I get a lot of "unable to find patch" or some such messages when I look at the texture lump in SLumpEd, and XWE shows that a lot of the patches are missing.

I already tried importing every single patch from classic Doom into the wad and adding them to patchnames/textures, but that didn't help.

The problem gets completely fixed if I simply delete the texture lump, but obviously all of the custom textures that I wish to use are gone as well.

Tutorials for adding textures that I've found on google simply tell me to import the graphics I wish, click on them, and hit add to texture in XWE. I do this and it creates the texture lump with the above problems.

This is the wad file, with the screwy texture lump, as well as all of the custom textures I currently plan on using.

As always, any help is appreciated. What annoys me is I think I've spent more time being forced deal with stupid problems like this than actually mapping.

Share this post

Link to post

I have looked at the wad, but I not really understanding what the problem is.

Why can't you just save the textures you want to keep, and re-import them into a fresh wad?

Share this post

Link to post

SLumpEd does a right royal job of screwing up pnames lumps by adding random crap to the patch names - here's how I did it in XWE.

First step is to open xwe.ini in your favourite text editor and edit the MainWAD path (near the end of the file) to point to your Ultimate Doom IWAD, making it XWE's default wad. Open a copy of dld.wad in XWE, delete the existing PNAMES & TEXTURE1 lumps, highlight your patches and select Add to Texture. Check the entries in the texture lump, if all is well - close the wad, exit from XWE and reverse the changes in xwe.ini.

Share this post

Link to post

Heh, that did it. Thanks very much!

Here I was thinking that it was some kind of weird dormant problem that I somehow caused when I originally worked on this wad 4-5 years ago.

Looks like I get to hopefully finish the layout for E1M6 tomorrow!

Oh yeah, anyone that actually has the wad from this thread for some reason, feel free to comment on the layout of the map. It's my first map since restarting this project of mine (E1M1-5 and E1M9 plus the E2 maps were made in 2004 or 2005 and are in dire need of a passover, especially E1M4, 5, and 9).

The level layout is roughly 50% completed (half techbase, which is finished, or close to it, and the other half being a dark underground passageway.

[Edit] I'm forbidding myself to start a project thread for this wad until I finish E1M7 at least, so if my laziness once again causes me to drop the project, I'll at least have Episode 1 done, hence the sort of side comment in this post now that the thread's main concern has been addressed.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this