Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
BlueEagle

[zdoom] Monsters don't attack the player?

Recommended Posts

I don't understand this. I've tested the map with different versions of Zdoom and GZdoom, which are in different directories with different configurations and I never got attacked?! Even if I shoot the caco, he just floats around me, but does not attack.

Share this post


Link to post

Alright, I've made a new directory, made a clean copy of GZdoom (latest) and put doom2.wad and this wad inside and it works. As soon as I copy my old configuration ini into this folder, the enemies don't attack me anymore.

Does anyone know what line of my configuration could cause this?

Share this post


Link to post

The only thing I could see would be autoexec-ing a file that runs the notarget command...

Share this post


Link to post

The problem still exists. Only with Hexen format levels. And if I delete the ini file, it works. But as soon as Zdoom has the configuration ini in the directory (even the auto generated one) and I start the level, the enemy is not attacking me.

Share this post


Link to post

Aim at the monster and type "info" in the console. Look if it has the FRIENDLY flag.

Again, though, when I tried your example file, the caco did attack me...

Share this post


Link to post

I can reproduce this bug 100%. Here is what I did:

make new directory
copy doom2.wad + gzdoom + wtf.wad inside
run the level with gzdoom
notice, caco attacks
quit gzdoom
run gzdoom again with the level
see that caco does not attack anymore.

when I delete the configuration ini and start the level, the caco attacks again.

I'm using WinXP btw if that info is of any use.

here is the info:

Share this post


Link to post

Very strange. All I can say is that it attacks me every time.

You sure you don't have an autoexec or something hiding somewhere as Gez suggested?

Share this post


Link to post

Is there an autoexec.cfg file in your directory? If so, what is its content?

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×