Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Archy

W_CacheLumpNum: 2316 >= numlumps

Recommended Posts

I keep on getting this error wen I just record a DOOM 1 lmp and try to play it back.

My doom.exe file is 715,493 bytes and my doom.wad file is 12,408,292 bytes so I don't think that is the problem. By the way, I am using DOSBox 0.73 on an HP OEM Windows 7 Home Premium 64bit (Yes I know, OEMs SUCK!) to run the game.

Share this post


Link to post

One way you can get an error like that is if you record a demo lump named like one of the lumps loaded from the WADs. Like, if you record something called e1m1.lmp, for example. In that case the engine will try to play back the level marker instead of the equally-named demo you made.

If that is your issue, just rename the demo to something unique and it should play back fine.

Share this post


Link to post
myk said:

One way you can get an error like that is if you record a demo lump named like one of the lumps loaded from the WADs. Like, if you record something called e1m1.lmp, for example. In that case the engine will try to play back the level marker instead of the equally-named demo you made.

If that is your issue, just rename the demo to something unique and it should play back fine.

AFAIK, EE and PrBoom+ are the only ports that will tolerate vanilla-format demos that are named the same as other wad lumps. PrBoom accomplishes this by not linking them into the wad directory at all; I did it in EE by making sure they stay inside their own namespace, similar to how sprites and flats work.

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  
×