Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
D_GARG

Which is the best lump editor?

Recommended Posts

yes, which is the best lump editor?
I have edited in Slumped and XWE today and i had my DECORATE fucked.

is there any that dont goes buggy and messes up your files?

Share this post


Link to post

XWE is famous for going buggy and messing up files. Slumped shouldn't. Worst it does in my experience is crashing abruptly, meaning that whatever work you had not saved yet is lost, but it doesn't corrupt the files.

There's also the SLADE3 beta. It's not feature-complete yet and well, it's a beta; but it's already good enough for basic lump management and editing text lumps. Though you might miss Slumped's syntax highlighting, as this is not implemented yet.

Share this post


Link to post

Yeah I wouldn't recommend using SlumpEd AND XWE to manage lumps in a wad. Choose one or the other. They don't get along very well at all.

I prefer Slumped because it's a little more stable and is a lot better about not doing things without asking. XWE doesn't have a save button and will automatically save upon exitting, which can be really bad in some situations that I occasionally get into where I had used Doombuilder 2 and XWE to open the same wad, and corrupt my work.

Share this post


Link to post

In my experience XWE is the number one cause of "corrupted" IWADs among active modders. As they will open an IWAD to take a look at something, inadvertently change something which XWE will then save. Personally I always write-protect all IWADs, its just safer that way.

Share this post


Link to post

another tip is to not have a WAD open in more then one program

for example building in DB(2) and having the same file open in XWE may and will cause the wad to get corrupted. in anycase if your file got corrupted while using XWE there should be a file named "<your wad name>.wad.001.bak" in the same folder as the WAD

try and check that one, your DECORATE data may still be intact.

Share this post


Link to post

i kind of solved it out, just using slade and doombuilder1 now, one at the time.

I have a new problem, I have added a weapon , a shogun which are used when pressing "3"

but if I have it already up, and presses "3" again, the entire game hangs itself up.

what shall I do about that?

Share this post


Link to post

might be the lower animation, or "deselect"

Deselect:
PISG A 1 A_Lower
Loop


if something is screwed in there the weapon will just freeze all other actions

Share this post


Link to post
Ahcruna said:

might be the lower animation, or "deselect"


ok, is NULL important?

Share this post


Link to post
D_GARG said:

ok, is NULL important?

What NULL?

Share this post


Link to post
Gez said:

What NULL?


for example:

___________________________________
Ready:
WSTG A 3 A_WeaponReady
Loop
Deselect:
WSTG A 2 A_Lower
NULL AA 0 A_Lower
Loop
Select:
WSTG A 2 A_Raise
NULL AA 0 A_Raise
Loop
Fire:
NULL A 1 A_GunFlash

Share this post


Link to post

I don't quite follow, where are you trying to add that?

[edit]

no you don't need that. the space you added NULL in is where the sprite name is supposed to be.

also you don't need to add A_* actions more then once, unless it's something special like sound effects


Ready:
WSTG A 1 A_WeaponReady
Loop

Deselect:
WSTG A 2 A_Lower
Loop

Select:
WSTG A 2 A_Raise
Loop

Share this post


Link to post

Where did you see this example with NULL sprites? Some people use that as invisible sprites, despite the fact that they shouldn't. TNT1 is the invisible sprite, not NULL. (If you ask me, NULL is a better name, but unless someone has a time machine and can change the code before Boom's first release, TNT1 is the only one that has the associated special coding to make sure it's valid and invisible.)

There's also no reason to use an invisible sprite here instead of WSTG like the rest of the state. It lasts 0 tics anyway.

Those things are used so that the weapon raises and lowers faster, making it nearly instantaneous like in, say, Quake.

Share this post


Link to post
40oz said:

PK3<WAD

If you're modding specifically for Doomsday/Vavoom/ZDoom or compatible, PK3>WAD. If not, then you won't be using PK3 anyway.

Folders > start/stop markers. Makes maintaining the resource archive a lot easier.

Share this post


Link to post

ok, found a clue to the source of this problem.

in the KEYCONF file i have
______________________
weaponsection "west"

addslotdefault 3 WensternShotgun
_______________________________

nothing more



what happens when i select the gun (3) and its the only gun in "3"
and i press 3 again, the whole game freezes unhelpebly.

whats wrong in here?

btw i have multiple KEYCONF files in my wad

Share this post


Link to post

Wintex will fuck your shit up if you use any non vanilla formatted files. Other than that it works fine. But I also think it got a very slow and clumsy UI.

XWE sure got it's bugs. But I know of only one bug that will fuck up your data. And I know when that happens. (If you try to save a WAD that you already got loaded in another program) It's pretty easy to avoid that. And even if I make a whoopsie and that do happen. I always have a one save back backup of the wad. :)

But to each their own.

Share this post


Link to post

Is it safe to use XWE to tweak resource files currently opened in Doom Builder 2? It wasn't allowed when I was using DB1, but now I can...

Share this post


Link to post
printz said:

Is it safe to use XWE to tweak resource files currently opened in Doom Builder 2? It wasn't allowed when I was using DB1, but now I can...


It's not, if you save in XWE it will corrupt the WAD so you will have to use the .bak file to restore stuff. even that wont save you some times though.

Gez said:

Delete them all.

People should not use KEYCONF for weapon slots anymore.
http://zdoom.org/wiki/Weapon_slots


agreed

kristus said:

Wintex will fuck your shit up if you use any non vanilla formatted files.[/B] Other than that it works fine. But I also think it got a very slow and clumsy UI.


Such as what exactly? (just a curious question =] )
I haven't had much problems adding none vanilla stuff in Wintex
adding resources as raw data works just fine.

anyway since I haven't staid on topic. =x

I use Wintex and XWE
Wintex is mostly because I can't add a transparent background on stuff I work with when I'm on my cellphone, so I just add the color Wintex replaces with transparency. also because I <3 Wintex being my first ever resource editor for WAD's that I used =)

XWE for everything else.

Share this post


Link to post
Gez said:

Delete them all.

People should not use KEYCONF for weapon slots anymore.
http://zdoom.org/wiki/Weapon_slots


it worked fully and Zero-Bugged with the DECORATE sulution.

CODE:

{
Weapon.SelectionOrder 1300
Weapon.AmmoUse 1
Weapon.AmmoGive 8
Weapon.AmmoType "Shell"
Inventory.PickupMessage "You got the shotgun! Lock and load!"
Obituary "%o was blown open by %k's shotgun."
Attacksound "DukeShotgun/Fire"
Decal "BulletChip"
Weapon.SlotNumber 3
States
{

properties goes before states :)

Share this post


Link to post
Ahcruna said:

It's not, if you save in XWE it will corrupt the WAD so you will have to use the .bak file to restore stuff. even that wont save you some times though.

Actually, I've done this several times and it didn't bang. Notice that I meant resource files, not level files. Even now I'm going to do it.

Share this post


Link to post
printz said:

Actually, I've done this several times and it didn't bang. Notice that I meant resource files, not level files. Even now I'm going to do it.

*facepalm* ah yes of course. I miss read it, yes what I said only comes in account when your editing a map in the same wad =)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×