Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
E.J.

zDoom/gzDoom screen tearing in Win2k

Recommended Posts

Hi all.

Just wondering if anyone else has ever loaded up a recent port of (g)zDoom in Windows 2000? I'm using Pro for this test, and I don't have this problem when running it in XP on the same machine.

I'm getting a tearing effect, even on the static screens... (like the title)

Share this post


Link to post

ZDoom or GZDoom or both? If it's both it's most likely system or driver related as they use completely different methods to draw graphics.

Share this post


Link to post

Yes, it's both zDoom & gzDoom.

Oh well. I'll just have to put up with it.

Share this post


Link to post

Well, typically XP and 2000 use the same drivers, are you using the same drivers between the two operating systems, or just the drivers provided by the OS?

Share this post


Link to post

Well, I copied over the drivers from XP, and installed them without any errors. The driver works fine compared to the 2K default, but the G/ZDoom issue remains.

Is 2D acceleration enabled? Quite possibly the screen update is going slow for you, usually happens when acceleration is disabled.

Where would I set this option, in-game, or through the 'ini'? I'll have access to the PC later tonight, so I can test it then.

Share this post


Link to post
E.J. said:

Well, I copied over the drivers from XP, and installed them without any errors. The driver works fine compared to the 2K default, but the G/ZDoom issue remains.


Where would I set this option, in-game, or through the 'ini'? I'll have access to the PC later tonight, so I can test it then.


dxdiag and/or Display Properties in control panel (under the Resolution Advanced Button).

Share this post


Link to post
GhostlyDeath said:

dxdiag and/or Display Properties in control panel (under the Resolution Advanced Button).

Okay, I checked, but no '2D acceleration' option was available. Actually, it wasn't available in XP either.

Win2k is too old of an OS to worry about incompatibility, but thanks for the help. I don't why I keep messing around with these older PCs...

Thing was that the difference between XP, and 2k, on this Intel 733MHz, 512MB RAM, with 32MB VRAM was full-speed on 800x600 resolution as opposed to 640x480 on XP.

Share this post


Link to post
E.J. said:

Okay, I checked, but no '2D acceleration' option was available. Actually, it wasn't available in XP either.

Win2k is too old of an OS to worry about incompatibility, but thanks for the help. I don't why I keep messing around with these older PCs...

Thing was that the difference between XP, and 2k, on this Intel 733MHz, 512MB RAM, with 32MB VRAM was full-speed on 800x600 resolution as opposed to 640x480 on XP.


Right click on the desktop, go to properties, go to the last tab that allows you to choose resolutions. There should be a button on the bottom that says "Advanced...", click that button. Then inside one of the tabs it should show a bar that you can slide left and right. There's 4 options, one side being full, and the other being none.

It's in there, it's been in every version of Windows, except Vista which moved it to device manager afaik.

Share this post


Link to post

I think I know what you're talking about. It's marked as 'hardware acceleration', and I've always left it on the default 'full' setting.

I played around with the slider bar, and lowered it until I reached the 'disable all DirectX & DirectDraw acceleration' setting. At that point the previous problem was longer there, but obviously it caused all sorts of new graphical problems...

I know Win2k didn't support all the DirectX features XP did, so maybe it is a DirectX, software, issue...?

Thanks for the help anyways. ;)

Share this post


Link to post

No I'm pretty sure Win2K supports everything Windows XP does in terms of Direct X.. speaking of that, did you update Direct X?

bring up dxdiag by going to start>run 'dxdiag' and find out which version it is.

The one installed by default on Win2k is older than the one XP will have.

Share this post


Link to post

Yeah, I had updated to the latest DirectX 9.0c redistributable, from this last February.

Share this post


Link to post
E.J. said:

I'm getting a tearing effect, even on the static screens... (like the title)


Can you describe that better? Perhaps photograph it? Because I recall some dude had posted here about getting a permanent deformed region on his screen, and it turned out he had the magnifying lens tool on the whole time -_-

Since it affects static screens too, it can have to do with refresh (unless you mean you get a sort of floating scanline like on a broken VCR). Have you tried different resolutions and refresh rates? What video card and monitor type are you using?

Share this post


Link to post

Okay, I figured it out. I was too focused on why the ports were behaving differently on the same PC hardware, same ini settings, but different OSes.

It was the monitor refresh rate. Oops... pardon my moment of stupidity.

The monitor only has one refresh setting, so all I did was turn on the vsync in the zdoom console.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×