Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
SonicIce

Edge doesn't play custom midis

Recommended Posts

I'm making a wad and none of my midis play in Edge. I'm using the latest version 1.34. The songs play in ZDoom, GZDoom, Skulltag, ZDaemon, Odamex, Eternity, MSDOS Boom, PrBoom, PrBoom+, and Legacy. But not Edge. I even deleted my whole Edge folder and started it again and still won't work. Whats up with this?

wad is here

Share this post


Link to post

Change the music device to TIMIDITY (in the sound option menu), and install a GUS patchset as per the README (which you probably did for some of those other ports) and then real MIDI files will work.

Share this post


Link to post
SonicIce said:

ok timidity works but why doesn't system midi work like every other port?

Our code only supports MUS format music, which was fine at the time the guy wrote it (something like 10 years ago), since everyone was using MUS then.

The code cannot "just be fixed", since MIDI is a lot more complicated than MUS. Hence the only choice is either keep what we've got, which works for all the IWADs and most pwads out there, or remove it and make everybody use the TIMIDIY option.

Share this post


Link to post

ok thanks for the info. if they were mus would they work and can i convert midi to mus?

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×