Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Building WiiDoom with devkitPro

Recommended Posts

I'm running WinXP SP2 32bit and used the devkitProUpdater-1.5.0.exe to install the following packages into c:/devkitpro:

Then I downloaded the following packages manually and extracted them to "c:/devkitpro/portlibs/ppc":

Then I downloaded "SDL Wii 11-28-2009.zip" and extracted it into c:/devkitpro (it already included a libogc directory).

Finally, I downloaded the WiiDoom source with Mercurial 1.6.

I opened up msys, moved to the wiidoom directory and wrote "make". Despite many warnings, it seemed to compile and link fine, resulting in a boot.dol of 2.214.144 bytes (not quite the same size as the precompiled one available for download).

I then copied the boot.dol to my SD card, overwriting the original, file. When I start the game via homebrew channel, I can choose to load the DOOM1 wad file, but after clicking "start", I get a DSI exception and a stack/code dump.

Any idea what I might be doing wrong?

Share this post

Link to post

The SDL-wii download is out of date. I built SDL from SVN and used that to build WiiDoom.

Share this post

Link to post

Thank you for your quick reply.

I got SDL Wii r89 from http://sdl-wii.googlecode.com/svn/trunk/ and built the libs. Here's what I got:

size: 1.740.070 bytes
size: 421.352 bytes
size: 396.782 bytes
size: 60.106 bytes
size: 1.299.678 bytes
size: 1.705.838 bytes
size: 124.352 bytes

The new bool.dol is almost the same size as yours, but still not quite: 2.198.976 bytes vs 2.199.040 bytes. The problem is that it still crashes with a code dump at the exact same moment.

Almost there.. maybe there's something else I'm missing?

Share this post

Link to post

That didn't do it either, I got another lovely codedump. The new boot.dol got a little bigger this time around though (2.199.680 bytes).

Would it help if I post the sizes of my freshly built libogc r4165 libs?
How about getting the devkitpro r4165 sources and building that one from scratch as well?

Share this post

Link to post

Thx, but no luck.

I got SDL WIi revision 88 with "svn co -r r88 http://sdl-wii.googlecode.com/svn/trunk/" and built it. "make all" didn't work, because sdl_gfx complained that there's no SDL.h, so I used "make" followed by "make install" seperately in each folder, which should be okay? (I deleted all r89 files in my devkitpro folder manually before building r88.)

Then I tried building WiiDoom with both libogc r4165, and after that, I extracted the "normal release" libogc-1.8.3.tar.bz2 into my devkitppc folder, overwriting r4165 for a second try.

The size of the boot.dol this time around was 2.199.648 bytes and 2.198.944 bytes respectively. The latter one is pretty promising, but I still got the usual code dumps with both.

This is really weird, by now I should have the exact same libraries that you've used. But I don't want to give up yet. I guess you used Linux and Eclipse to build WiiDoom? Could you pls tell me the exact version of your OS and IDE? I suppose that if I replicate your build environment, there's no reason I shouldn't be able to get it working.

Debugging my boot.dol sounds like a good idea, that's propably what I'll have try if everything else fails. Though I'm not familiar with Wii development, so that could prove to be quite difficult for me.

Share this post

Link to post

I used Mac OSX 10.5 and Eclipse. That actual release build is simply from the command line.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now