Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Porsche Monty

Why do I get tearing...

Recommended Posts

...in vanilla-oriented source ports such as Chocolate Doom when I disable vsync? I mean, a hypothetical refresh rate equal or higher than 35hz should make it impossible for tearing to occur, granted they're indeed outputting at 35fps, which's vanilla Doom's maximum frame rate. I've gone as far as 120hz and I still get tearing.

It'd seem to me that this is a case of uncapped framerate altered to look like 35fps, but what do I know?

Any hints?

Share this post


Link to post

Try a multiple of 35, like 70 Hz (the only practical one in most cases), on a CRT or a TFT that can actually output 70 Hz without any intermediate processing that should eliminate visible tearing.

Share this post


Link to post
Maes said:

Try a multiple of 35, like 70 Hz (the only practical one in most cases), on a CRT or a TFT that can actually output 70 Hz without any intermediate processing that should eliminate visible tearing.


Happens with any refresh rate (yes 69.8, 70.0, 70.2, etc, they all show tearing). All you get with multiples is stutter-free movement.

Share this post


Link to post

What kind of monitor are you using? Also, since you disabled VSync, drawing is no longer tied to the screen's actual refresh, so you get to see partially drawn frames. In extreme cases you might even see two halves or two percentages of entirely different scenes (e.g. by spinning around very quickly or accessing/closing the menus very quickly).

Share this post


Link to post

Even if the numbers are coincidental, there's no guarantee that the screen isn't updating in the middle of a pass. Only VSYNC does that.

Share this post


Link to post

Why do I get tearing when I turn vsync off?

BECAUSE THAT'S WHAT VSYNC IS FOR

Share this post


Link to post

Not everything that doesn't do vsync under similar scenarios actually shows tearing here, so I thought there could be other forces involved, but I guess with vsync off it's just hit and miss.

Share this post


Link to post

Vsync is what stops tearing. The frames are no longer synchronized to the monitors refresh rate without it, so sometimes you get multiple frames in different parts of the display, which is what we refer to as tearing.

I wish I could find a way to get vsync working on dosbox, for some reason even if I enable it in the .conf or try and force it with the nvidia control panel it doesn't work. Hm.

Share this post


Link to post

Mike.Reiner said:I wish I could find a way to get vsync working on dosbox, for some reason even if I enable it in the .conf or try and force it with the nvidia control panel it doesn't work. Hm. [/B]


Works for me, at least on WinXP with ForceWare 94.24, all I have to do is set the output to "ddraw" and make sure vsync is set to either "Application-controlled" or "On" Don't expect framerate to be as smooth as in real Dos, though.

Share this post


Link to post
Porsche Monty said:

Works for me, at least on WinXP with ForceWare 94.24, all I have to do is set the output to "ddraw" and make sure vsync is set to either "Application-controlled" or "On" Don't expect framerate to be as smooth as in real Dos, though.


I just managed to get vsync working by changing output= to opengl.

Framerates seem fine, I've never had any problems attaining the full 35 FPS in doom through dosbox with my machine.

Share this post


Link to post

What I do is press and hold down any of the turning keys for like 10 secs. If I get any stuttering at 70hz with vsync on, something's not right. DosBox can definitely handle much higher framerates on this machine, I've seen it in action with other games, but the stuttering will still be there, killing the smoothness of the movement every x seconds, and I'm having exactly the same problem with Eternity in -directx mode.

Share this post


Link to post

I remember my old Athlon 64 3200+ couldn't play dosbox without the occasional stutter, but even my old 4200+ X2 plays it fine.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
×