Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

Specific slowdown areas in a large level

Recommended Posts

So people who test my maps and I are having large slowdown problems in a particular part of a map, specifically the eastern lava cave areas in map21 of newgothic.
link. It could possibly be the sheer number of monsters, although at most maybe 800 are active at this point, or maybe it has to do with the angles of visplane draw, considering you could probably see a visplane all the way on the other side of the map at the entrance to the caves. However that part isn't as bad as inside the caves, which has the worst slowdown in the map despite having that 800 or so active monsters and much less detail than many parts of the map. Possibly it could be the way the map is built? maybe a bad range of sector/linedef numbers? I don't know. Maybe someone could point out the problem?

TL;DR - My huge map has major slowdown in a place it should't, wth?

Oh yeah, you must use prboom +, for the extended zdbsp node support.

Share this post

Link to post

Heh, that's a really interesting slowdown. It's definitely monster-related, since there's no slowdown on -nomonsters. It's not the number of monsters either (I think) though, since if it was you'd have slowdown everywhere (there's a few parts of the caves where there's no slowdown) so...it's either the renderer going nuts or maybe the AI has problems with too many sectors together with the missing REJECT (IF it's this THEN removing monsters would work, but I'm skeptical).

Also removing the rest of the map fixes the slowdown so there's nothing wrong with that area alone.

EDIT: Zdoom has no slowdowns whatsoever for me (prboom+ is baaaad). The map does take much longer to load in ZDoom, but the caves are perfectly smooth.

Also, make line 8320 impassable. It's the tiniest thing, but still, make it impassable. :P

Share this post

Link to post

I don't get any slowdowns in prboom-plus, but since it loads instantly for me in ZDoom and does not "take much longer to load" I guess my computer is just outperforming the problem.

You could check if you have "rescue dying friends" (Options -> Setup -> Enemies) enabled and disable if necessary.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this