Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

Weird bug involving DB2 and a zdoom map

Recommended Posts

I've just downloaded DB2 version and was working on a little zdoom map, and when i added a couple of vertices, every thing on my map went to hell. Perhaps some pictures can better explain the situation.

this pic was taken without the extra vertices. Everything is normal. This is a screenshot of the part of the map that's about to be edited.
This is a screenshot of the map with additional vertices, and when i test the map, it looks like this. Note that in the latter screenshot there should be three imp's, a shotgun on the teleporter and two green firesticks, as given away by the green dynamic light. The weird thing is, if i delete the extra vertices and go back to the configuration that worked, the problem is solved.

What could be the problem? Here is the offending wad, in case you'd like to take a look at it.

EDIT: I've narrowed it down to a single vertex triggering the bug. Like this everything is normal. Here, the bug appears.

EDIT 2: I've tested this with DB2 version and the same thing happens.

Share this post

Link to post

Bugs should go here, but I've linked this there. I have been able to reproduce the problem, although for me it doesn't start in the sky with no things, but in the void without textures (only HOM) yet the walls seem to block me still. Anyway, I'll have a look at it, thanks.

Share this post

Link to post

After some testing this appears to be a bug with the latest ZDBSP nodebuilder, not with Doom Builder. I have linked your bug report on the ZDoom forum. You can get around this problem by using a different nodebuilder (ZenNode proved to work well).

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this