Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Glass Rook

NDCP 3D Floors in GZDoom?

Recommended Posts

I'm playing through the megawad New Doom Community Project (the first one) with the current version of GZDoom and have made it to MAP19. I can't go anywhere because I can't walk under the 3D floors at the beginning to get to any of the doors. I thought GZDoom supports 3D floors; am I mistaken?

Share this post


Link to post

Not sure how these floors are implemented, but it sounds like an older-style bridge using bridge things. There's a flag in your options menus somewhere called "infinitely tall actors" or something of that sort. Turn that off and try it again. That flag is there because originally in Doom, you couldn't pass over or under other things in the map.

Share this post


Link to post

"Actors are infinitely tall" is already set to "no". Sounded like a good idea though, and I don't know why I didn't think of checking that myself. Still I can't walk under those bridges, though I was able to walk under bridges in the Castle of the Wolf map.

Share this post


Link to post

You say the current version of gzdoom. Which version ? Using gzdoom 1.5.00 I had no problems at the start. Walked under the three bridges and opened the door on the left.

On the other hand using the latest gzdoom 1.5.02 , level 19 crashes every time for me with a very fatal error.

BTW the bridges use the vanilla self referencing sector method for bridge control.

Share this post


Link to post

Come to think of it, there were a few issues that ZDaemon was having with vanilla broken-sector hacks, which was later fixed via a compatibility flag. Check in GZDoom's compatibility options for anything mentioning self-referencing sectors (or sounds like it). ZDoom, IIRC, has such an option which should fix the issue and let you pass through the affected sectors.

Share this post


Link to post

I'm using GZDoom v1.5.2 with svn build vR936.

I changed the compatibility flag for the self-referencing sectors but it did not solve the problem. Guess I'll try an older version of the sourceport or svn build.

EDIT: I also just tried with svn build vR959, but had no luck.

...or I could just "noclip" through the map...

Share this post


Link to post

I just tried it with v1502 and it crashed for me but I tried it earlier with v1500 and didn't notice any problems.
Looks like the map has lots of problems (unclosed sectors...).

Share this post


Link to post
4mer said:

I just tried it with v1502 and it crashed for me but I tried it earlier with v1500 and didn't notice any problems.
Looks like the map has lots of problems (unclosed sectors...).


Part of these problems are not real problems in the map, actually, but "ghost" problems created by the two-pass node-building system that GZDoom uses. Builds between r875 and r943 are very unstable because of that.

Share this post


Link to post

It wasn't so much the two-stage node building that caused the errors but a poorly made optimization in ZDoom's polyobject code that forgot to take it properly into account - and it took a few revision to iron out the problems. Unfortunately the 1.5.2 release fell right in the middle of this phase.

I'll release an 1.5.3 version as soon as I am confident that the new menu system is working properly.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×