Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Geonightman

FLAT problems.

Recommended Posts

So I am making a new map and just found out how to import new textures. I have successfully imported several PNG's and they all work, however when I am trying to make them FLATs the image goes grayscale and when I open the editor it becomes an unknown lump. It also will not appear in the level editor. I have tried this in SLumpEd and XWE. I am using Doom Builder 2. I have also double checked that they were 64x64px.
Can I get some help with this please.

EDIT: I tried adding the Marker F_END and now the files seem to be staying as flats in the wad, but they still do not show up in Doom Builder 2

Share this post


Link to post

Depending on what port you are aiming your WAD to support, it might be easier just to put all your graphical lumps bewteen TX_START/END markers, as textures and flats are no longer distinguished seperately by the newer engine ports.

The images may be going greyscale because you are attempting to translate them into the doom palette. Either leave them untranslated (meaning they will show up fine outside of software rendering), or use a graphics program like gimp or photoshop to translate them into the correct palette range.

Doom Builder 2 has a habit of only showing either flats or textures in the selection list depending if you are altering a floor or wall. That's why its easier just to lump everything as a TX_, which generally makes it show up in both.

Share this post


Link to post

The port is going to be for Skulltag.

EDIT: I also tried putting TX_START and TX_END (with every texture between them) and it did not make them appear in flats.

DOUBLE EDIT: I figured out the problem. I had accidently set the mode of Doom Builder to Doom 2 (as opposed to Skulltag (Doom in Hexen Format)). Thank you for you help.

Share this post


Link to post

Did you save each map as a Doom flat? Under the "Image" menu (if using XWE anyway) you have to choose any lumps you want to appear as flats and save them as Doom flats if you want them to appear and work properly. This is a mistake I've made a couple of times...

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×