Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[ R1303] TRANMAP.dat problem

Recommended Posts

I have created a TRANMAP.dat with tran_filter_pct set to 32 and converted it to TRANMAP.lmp using MAKTRLMP.EXE (part of Boom Editing Utilities package - download).

During file conversion MAKTRLMP.EXE prints a warning to the console:
"One or more CON code pages invalid for given keyboard code"

The transparency effect is broken when using the created TRANMAP lump in a map.

If I repeat the same procedure using Boom 2.02 (running in DOSBox) MAKTRLMP.EXE does not complain and I get the desired results.

I have made two test levels (download link at the bottom of this post):

  • boomrain.wad - Demonstrating the desired Boom 2.02 behavior
  • boomrain_ee.wad - Demonstrating the broken Eternity Engine R1303 behavior
I have also included Boom_TRANMAP.dat and ee_tranmap.dat in the zip.


Share this post

Link to post

EE's cached tranmap.dat files cannot be used with the BOOM tranmap utility any longer because they contain some versioning metadata in the header. This was necessary because Lee Killough made a mistake in the generation code for the file format which left out 2/3rds of the palette data.

This was never obvious until esselfortium caught it while working on his Vaporware project, which uses a different palette. Since his palette never varies from DOOM inside the first 1/3rd of the colors (only in the latter 2/3rds), the tranmap.dat file would be detected as matching the current palette and the translucency lookup loaded would become non-functional.

Share this post

Link to post

Indeed. Options for generating a tranmap lump include:

1) Use PrBoom or PrBoom-Plus to do it, combined with MAKTRLMP.EXE.

2) Use an image editor that supports layers, open up the palette you're using as a 1x256 image, and stretch it out to 256x256. Make another layer that rotates it 90 degrees, and set the opacity level on it to the desired level. (I may have accidentally mixed up whether the foreground or background layer needs to be rotated. I guess you'll know it if you end up with 68% opacity ingame instead of 32%.)
If you're using Photoshop, here is a template I made to do the job with the standard Doom palette.

Assuming I didn't get it backwards when I made these a year or two ago (if so, they're just the inverse of the translucency level I'm saying they are. :P), here's a 0, 25, 50, 75, and 100% tranmap set with the standard Doom palette:

Once you've generated your tranmap, import it into your wad and use either XWE to save it as a flat (yes, a 256x256 flat), or use Slade3's graphics converter to convert it to a Raw Graphic.

Hope this helps. Sorry for the uncertainty with it; it's been a while.

Share this post

Link to post

@Quasar: Thank you for clarifying. It is interesting how underused the palette and tranmap effects are given how easy it is to use them.

@esselfortium: From now on I will use the second option, so thank you very much for the .psd and the description of the entire procedure. I guess this is how you made those cool translucency effects. :D

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now