Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
DoomF4nG4mer

New Enemy Sprites

Recommended Posts

GreyGhost said:

Try reading the descriptions. Tormentor's Bestiary is also worth checking out if you haven't already stumbled across it.


:O wow now this was the place i have been looking for! Thank you very much GreyGhost!

Share this post


Link to post

Hmm i have recently downloaded some Enemy sprites and i am trying to import them to Doom Builder (Notice that i am using Doom Builder 1 because Doom Builder 2 has a problem with Direct3D) And i know the method on how to spawn them using the TID but the weird thing is that when i am checking out the Decorate script of the Monster the TID is not visible or not there? What happened how am i going to import monsters in Doom Builder?

Share this post


Link to post
DoomF4nG4mer said:

Hmm i have recently downloaded some Enemy sprites and i am trying to import them to Doom Builder

Why do you care? Just use the editor number. Doesn't matter one whit if DB tells you it's a ??? rather than a dark imp, as long as it works in the game.

DoomF4nG4mer said:

And i know the method on how to spawn them using the TID

No. You can only give a TID to something that is already spawned. Are you confusing TID and editor number? Not the same thing at all, but I've seen that confusion in many places recently. It's like the new "cyan is transparent" mistake. (Hint: cyan is not transparent.)

See this for a little definition of the ten thousand different kinds of numbers that can be used to refer to stuff.

And if the actors don't have an editor number defined in their declaration, you can just add one yourself. Refer to this list to see which numbers are available.

Share this post


Link to post
Gez said:

Why do you care? Just use the editor number. Doesn't matter one whit if DB tells you it's a ??? rather than a dark imp, as long as it works in the game.


No. You can only give a TID to something that is already spawned. Are you confusing TID and editor number? Not the same thing at all, but I've seen that confusion in many places recently. It's like the new "cyan is transparent" mistake. (Hint: cyan is not transparent.)

See this for a little definition of the ten thousand different kinds of numbers that can be used to refer to stuff.

And if the actors don't have an editor number defined in their declaration, you can just add one yourself. Refer to this list to see which numbers are available.


Well i actually did create my own Editor Number on that monster's decorate lump and i entered it in Doom Builder and when i tested the map with the Enemy it just appeared as a Diamond shaped ! so is there anyway i can fix this?

Share this post


Link to post

There are a number of reasons why you'd get the exclamation mark. Presumably, either you do not have the sprites for your actor, or you forgot to put the DECORATE lump in the file or files loaded with ZDoom, or both.

Share this post


Link to post

Exclamation mark? Oh, yea. I've met some during my first mapping, as I've added some DooM II monsters to a E4M1.

Share this post


Link to post
Gez said:

There are a number of reasons why you'd get the exclamation mark. Presumably, either you do not have the sprites for your actor, or you forgot to put the DECORATE lump in the file or files loaded with ZDoom, or both.


Okay Problem is solved now i can now go back and add more monsters now!

Share this post


Link to post
Guest
This topic is now closed to further replies.
Sign in to follow this  
×