Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Freedoom, no monsters, no level exit

Recommended Posts

I'm using Freedoom on Gentoo, compiled with the doomsday flag. It runs fine, but no matter what I do, there are no monsters and no way to exit the first level - or any other level when I idclev to it.

What the frag am I missing, here?

Share this post

Link to post

I was really hoping someone who actually recognized what you are trying would answer, but I will try to give what help I can. I run (and develop) DoomLegacy on Linux 2.4 and Linux 2.6, (Slackware) and have not had any trouble with FreeDoom.

* I do not recognize "Doomsday flag". Is that a flag to Gentoo to get the Doomsday engine installed, perhaps ??
DoomsDay is a Doom Engine, but I have not used it.
A web search shows other sites with DoomsDay specific help.
There are reports of DoomsDay working with other Linux ports.

* You can go to the DoomLegacy web site and download DoomLegacy 1.44 for Linux 2.6 (or 2.4) (32bit or 64bit) and try that, to see if it is
an engine installation problem. Or try prboom, which I know works on Linux.
See DoomWorld source ports for all kinds of site pointers.

* You get nomonsters when the engine is started with a flag like
-nomonsters. Otherwise it is standard to have the monsters from the wad loaded.
If you actually have FreeDM, then that does not have monsters.

* Cannot exit the level. This is generally a wad problem, but here we do not even know what wad you are playing, and can only assume it is FreeDoom. If it was FreeDM then it would make more sense because that is a Deathmatch wad with no monsters.

* Exactly what are you seeing on that level?

* FreeDoom starts with a room with windows that overlook a depressed area with dead trees, and has a corridor to a switch.
On the far side of MAP01, the exit switch is on the back side of the switch pedestal (after crossing the green ooze). The switch on the front side just opens a door to a secret passageway.

* FreeDM is a closed area with a big FreeDM sign on the wall.
FreeDM levels are not really meant to be exited, so the exits are not very evident (I think it actually does have them).

* Any other variation is not FreeDoom, and any issues that you have with a random level wad would be difficult to diagnose without identifying it. Deathmatch wads will not have monsters and probably do not have exits either.

Share this post

Link to post

I had forgotten to return to this thread when I solved it.

I'm on Gentoo Linux. The ebuild maintainers for "freedoom" created an ebuild that actually installs FreeDM, not Freedoom. I downloaded the Freedom wad manually and opened it in GZDoom and was able to play it without issues.

I'm not going to report a bug to the Gentoo ebuild maintainers, though, as they Never Listen.

I appreciate the replies, though. :-)

Share this post

Link to post
This topic is now closed to further replies.