Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
HXCpr0n

Deep water glitch (screens included)

Recommended Posts

I'm sorry if this is a retarded question.. but I just can't figure it out no matter how much tinkering I do. I have a map - Skulltag - Doom in Hexen format. Now, I have a lava pool surrounding an island, and (it happened on my other map too) if, say, a player rocket jumps to a ledge on the other side of the island, they will start swimming in mid-air! (and take damage since I set a sector_setdamage script).

Here's 2 screens of what I'm talking about.

http://img576.imageshack.us/i/screenshotdoom201012052.png/
http://img263.imageshack.us/i/screenshotdoom201012052.png/

So, the deep water itself works, but if you happen to reach a certain height above my pool, you begin to swim in mid-air (only in the sector of course). I also set a sector setcolor script and it does not appear when I swim in mid air. Any idea on how I could fix this?

Share this post


Link to post

It's been quite a while since I've used transfer heights. If you did set the deep water thing in your dummy sector, make sure that the ceiling heights for both sectors (dummy sector and affected sector) are the same. Otherwise, you can end up transferring that extra space near the ceiling as well.

Share this post


Link to post
HXCpr0n said:

So, the deep water itself works, but if you happen to reach a certain height above my pool, you begin to swim in mid-air (only in the sector of course). I also set a sector setcolor script and it does not appear when I swim in mid air. Any idea on how I could fix this?

What are you using to make the lava "swimmable"? If you are applying gravity specials then you may be doing things the wrong way and it may be the source of your problems. If you insert a Water Zone thing (Type 9045) into the control sector for the deep water, you won't have the floating-above-water problem you're seeing.

Share this post


Link to post
ReX said:

What are you using to make the lava "swimmable"? If you are applying gravity specials then you may be doing things the wrong way and it may be the source of your problems. If you insert a Water Zone thing (Type 9045) into the control sector for the deep water, you won't have the floating-above-water problem you're seeing.


It's the deep water thing in zdoom. I put it in the dummy sector and I've used it in other wads. It does work for the part of the sector that I want to be swimmable, but the effect is just transferred and repeated at a certain height above the pool.

Share this post


Link to post

Deep water can mean so many things. What you're talking about is basically the Boom feature.

Share this post


Link to post
Gez said:

Deep water can mean so many things. What you're talking about is basically the Boom feature.


Well, it is the same thing Rex is talking about - Thing 9045 in Zdoom. I put it in my dummy sector and used transfer heights. The floor of my dummy sector is the height of the top of the lava, and the ceiling in reflects the height of the pool. They have the same heights and I'll double check right now that I did the math correct

Sorry if I'm a noob to this.. I don't really know much about boom, legacy, UDMF, Eternity, jdoom, or any of the other formats. I only really map in zdoom - doom in hexen format.

Share this post


Link to post

When I touch up or write an article in the ZDoom wiki, I try to mention the feature's history. So if something comes from Boom or another port, it says so.

Anyway, the ZDoom Transfer_Heights line special contains a flag, 8, which makes the zone swimmable without needing to mark it with a WaterZone thing. Have you tried this?

Also, if you map with Doom Builder 2, you should try UDMF instead of Hexen format. For the end-user, it's mostly identical (same action specials, etc.) but the difference is that many of the little things that required scripts or complicated workarounds can now be set a lot more simply.

Share this post


Link to post

Well, I did what you said. I took the deep water thing out of the dummy sector, and set the transfer heights special 8 (swimmable below fake). This didn't change anything (worth a try though) and I can still do some scuba diving in mid air as well as where I want to in my pool.

On a side note, if that is the case, then I will be using UDMF format next time I map for sure thanks for the tip Gez.

Share this post


Link to post

Vaders Blackrock map had this same problem that if you went high enough into the sky, one would enter a swimmable area, it has something to do with the sky height and the ceiling height of the dummy sector... obviously... so just try playing around with this, do some really weird stuff, it will most probably go right IF the problem is exactly the same as the one in Vaders Blackrock...

Share this post


Link to post

Thanks Icytux! I fiddled around with just the ceiling height of the dummy sector and it's fine now. Before, I was messing around with the floor height too and wondering why it was all messed up when I tried it. Turns out the floor of the dummy sector represents the ceiling of your swimming pool, thus changing it changes the top of your pool (you probably already knew that :P)

I just assumed changing the ceiling in the dummy sector would cause a similar error and didn't try it, but it seems that that is the solution.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×