Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
General Rainbow Bacon

New switch doesn't light up

Recommended Posts

Make sure there aren't switch textures both on the upper part and the lower part of the sidedef. For some reason the lower part gets inhibited from animating because of this, and monsters won't be able to activate the switch even if the switch is monster-activateable (Boom).

Share this post


Link to post

No, there aren't, I inset them. But whatever, I'll just use the stock switches for now. The sound doesn't happen either so it's probably something that requires me to write code that I don't have the patience for.

Share this post


Link to post

Did you edit the SWITCHES (Boom) or ANIMDEFS (ZDoom) lump? It's required to edit it if you're using new switch textures.

Share this post


Link to post

Then you've gotta get swantbls and read its readme.

Share this post


Link to post
printz said:

Did you edit the SWITCHES (Boom) or ANIMDEFS (ZDoom) lump? It's required to edit it if you're using new switch textures.


Unless you are using Doomsday. Doomsday's XG is smart enough to treat any SW"1-2"XXXX texture as a switch without need to write a lump.

Share this post


Link to post

Any easy way to do it without having to compile your own SWITCHES lump, is to just extend or replace some of the existing switches.

If your game is for Doom 2, you have lots of switches that are leftovers from Doom. For example: SW1BRCOM, SW1BRN1, SW1STARG, SW1STON2, and SW1STONE are all identical. You can just sacrifice a couple of these and use TEXTURE1/PNAMES to create whatever switch textures you need.

Share this post


Link to post

What happens if I edit the internal Doom.exe tables to include one extra switch and one extra animation? As you may know, there are tables just like SWITCHES and ANIMATED right inside Doom.exe, and each is padded at the end by a whole amount of zeros which can be replaced with yet another switch or animation entry. Surprise, when I tried it, it worked. But can it affect the stability of the engine?

Share this post


Link to post

A question: I know that ZDoom-only scripts (MAPINFO, ANIMDEFS, etc.) don't work with Boom, but do Boom scripts work on ZDoom ports?

Share this post


Link to post

Of course they do. There aren't many Boom features that ZDoom does not support. (On the top of my head, I can think only of TRANMAP hacks.)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×