Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Doom64 EX 2.0a (Feedback Build) - Updated 3-12-11

Recommended Posts

UPDATE - 3/12/11
There are only a few remaining bugs left but as I stated before, I will NOT release an official build until all of these known bugs are addressed and fixed. I understand that some of you are waiting to begin editing for Doom64, unfortunately I won't be working on the docs nor the editor until the next official release is out.

I really appreciate everyone's effort to track down these bugs and to help make Doom64ex stable for its next release.

Current bugs - last updated 3/12/11:
* DEMO1LMP through DEMO3LMP are out of date
* DEMO2LMP through DEMO3LMP are failing to play
* Z_Malloc freed pointer without zone ID error when finished playing demos
* (Map28) Lost souls not responding
* Double click use not working - low priority
* Random (unknown) crash coming from ntdll.dll

Fixes and Updates - 3/12/11:
* Updated executable icons
* Fixes for melee weapons and autoaim

Fixes and Updates - 3/10/11:
* Plasma buzz sound issues fixed
* Map13 music (Mp3/OGG mode) plays
* Ability to switch between chainsaw and fist (without beserk)

Fixes and Updates - 3/06/11:
* Rendering logic for clouds is now accurate
* Water affect tweaked
* Fixed player getting stuck in edges of closing sectors
* Fixed 'sticky' wall running bug
* Wall running logic updated to match original N64 version
* Thing's position is checked upon level load (removes them if they are stuck in another thing - see Final Outpost for an example)
* Fixed animation for lava flat (see Pitfalls for example)
* Major changes to fog logic. Attempted to make them as close to the original as possible.

This is NOT an official build so expect unfinished features and bugs to be present here, but the whole goal is to get user feedback and any newly discovered bugs in its current state.

There has been a lot of changes and improvements since 1.4.

----Current changes----

* Option to display automap as an overlay
* Accurate algorithm (from N64) for drawing the triangles
* Option to display things as sprites
* Holding down spacebar allows dragging/panning of the automap with the mouse. Left/Right buttons zooms map in/out.
* Option to mark keys/locked doors (for new Doom users)

Game Stuff
* Accurate demo playback behavior
* Updated tweaks to further match accurate enemy behavior
* Update to macro system to further improve accuracy to original. (Map03 had some scripted events that didn't function properly)
* Compatibility option to use N64's collision detection
* Numerous improvements to player behavior
* Player move speed updated to match original. Entire movement code was redone to match behavior.
* Laser codepointer redesigned to match original
* Teleport system redesigned to match original
* Redesigned savegame system
* -nosound param added for disabling sounds
* -noxinput param added to disable xinput api

* XInput API (Xbox 360 controller support)
* Better mousewheel support
* Slightly better mouse support

* Accurate N64 behavior for menus
* More options added

Status Bar
* Crosshair support
* New option to change layout of status bar to match the Absolution TC
* Chat system for multiplayer
* Display player names for multiplayer

* Improved cvar system
* Mousewheel scrolls console log up/down
* Auto completion of cvars when tabbing

* Improved echoing/reverb system

* Ability to use cheats and modify cvars across network

* Major optimization tweaks
* Improved rendering mechanics
* Sky and wipe mechanic updated to match accurate behavior

* Sounds replaced by .OGG format
* Improved algorithm for converting N64 palette to PC palette format (Thanks DaniJ)

----Known Issues----

* Random popping in the sounds when echoing. This is all but problems coming from SDL_Mixer and I do have plans to replace this godawful library
* Possible crashes or glitches when running on lower end graphic cards.
* Have had numerous exception issues with igldev32.dll (Map24 - No Escape is one of those maps that had many problems with this .dll)
* Hud issues when texture fitting is set to padding
* Wadgen fails to detect when a rom needs to be byte swapped (Can only detect .Z64 formats only)

Anyways below is the link. If there's any suggestion to improve the launcher or any current feature please post it here. I plan on adding better support for widescreen modes and to further improve the launcher interface. I will probably release the actual build once I've gathered enough feedback and squashed all of the major bugs.

Doom64 EX requires AT LEAST OpenGL 1.1 to handle all effects and texture combining methods. Doom64 EX is aimed to run on very low end machines and will use only the most basic rendering features (for now) so don't expect it to win the visual department. If there's any machine that you're having problems, let me know and provide the specs.

EDIT: Please re-run WadGen and generate a new IWAD for this build.


Also, editing support is still undocumented and unsupported. This will be something that I WILL work on after the next major build is released.


Share this post

Link to post

This works nicely so far. The older version and this version had a problem asking for msvcr71.dll, but I found it online and put it in the directory to make it work. Another thing I saw was a switch to fullbright when changingg the filtering mode in the menu, which goes away when restarting the level.

I recently played Doom64 in an emulator, and a big improvement I hear here is the correct sound panning. I also look forward to seeing mipmapping modes implemented.

Share this post

Link to post
phi108 said:

Another thing I saw was a switch to fullbright when changingg the filtering mode in the menu, which goes away when restarting the level.

Interesting, filtering does that too? I had a problem with setting gamma and texture fitting would cause it to go fullbright. Has something to do with the textures being dumped and screwing over the texture combiners. Not sure whats going on with that. I'll keep poking around and see whats causing that to happen.

Share this post

Link to post


The generated IWAD is now about 3 megs smaller than before, as a bonus from the Ogg Vorbis compression.

Share this post

Link to post


I have been having some problems mainly regarding savegames.
I already communicated to @Kaiser to tell him about this problems, but I would like to follow up about this problem, without spamming him with more emails.
To summarize the problem: Savegames are still broken in this version of 64 EX. The steps to reproduce the problem I'm mentioning (at least in my case) are:

- Start a new game (I tested with Skill 2 and 3).
- Finish the level while opening the teleporter to Hectic: Go around the level exploding the barrels minus the first (no apparent specific order, I once exploded them in order, then ran AMOK exploding them one each another).
- Return to the beginning by using any of the two teleporters.
- Explode the last barrel and go to Hectic.
- Save in the beginning of Hectic (doesn't matters if the fade-from-black effect is still on or if you move at least from the spawn point).
- Die.
- Try to load the game.

In my case, this error occurs:

P_UnarchiveSpecials: Unknown tclass 48 in savegame.
I have not tested saving in other places inside Hectic, like after killing the Arachnotrons, or anything.
The error doesn't occurs if I'm still in Map 01 (apparently).
I'll keep on testing.


Other error that had just occurred to me when I was posting this happens in the demo title (I have to love the title song). I was running Doom 64 EX to really test if errors occurred in Map 01, and in the middle of the demo I pressed Return (the NumPad key) to open the menu. I had this error:
Z_ChangeTag: an owner is required for purgable blocks.
Source: E:\sources\Kex\SRC\g_game.c:1319
In my case pressing any key in the demo brings up that message. When the copyright screen appears (before the demo) there's no problem at all (any key brings up the menu).


Another problem is with the Restart Level option in the Pause menu. First of all it mutes the music in the level. Also, you get to stay with everything you have obtained until you have used that option (not like I'm complaining ;) ).


Finally, I'm reporting on to confirm the bug phi108 said (changing filtering adds fullbright to the map).

Share this post

Link to post

Both Z_ChangeTag owner error and the failing texture combiner setup is fixed.

+ Build and bind a 2x2 white texture for TEXTURE1_ARB through TEXTURE4_ARB.
+ Removed R_GLBindBlankTexture. This was more of a hack and caused some issues with the texture combiner system
+ Clean up to replace R_GLBindBlankTexture with proper coding (using glDisable(GL_TEXTURE_2D) instead)
+ Free demobuffer instead of changing tags. No user was assigned during allocation anyways.

@ Tamhvm: Are you using that savegame file from an older build? I can't repro this.

Share this post

Link to post

I can confirm the Hectic save bug here. All I did was play through MAP01, saved as soon as the map loaded, and the game crashes as soon as I try to load that save. Same error.

One minor suggestion I have is to make Y quit the game automatically like normal at the quit game menu instead of having it select Yes.

Share this post

Link to post

Still superbright.

Gfx card GF440MX/64MB/ForceWare 93.71

Edit: The MX440 seems to lack support for some ARB_something feature - so superbright will always prevail on this card.
Tried the new version on a 9600GT and everything's dandy.
Good job.

Share this post

Link to post

Kaiser said:
@ Tamhvm: Are you using that savegame file from an older build? I can't repro this. [/B]

No, when I saw this version of the engine I erased everything minus the ROM (minor note: I left only the ROM, not the old generated IWAD).
I did the run I mentioned from ground zero. No prev. version savegame.

EDIT #1:
Checked the new build.

I'm not having the full bright problem when changing filtering from Linear to Nearest. Thus I would say it was solved.

I'm still having the savegame load problem in Hectic, saved when the fade effect is still going, when loading this I get an error with the same tclass number as with previous post (48).

I waited until the effect ended and saved other file. Loading the savegame this time got me an error with a different tclass number like this:

P_UnarchiveSpecials: Unknown tclass 43 in savegame
I killed the Arachnotrons and returned to the middle sector and saved, when loading I get this new tclass error:
P_UnarchiveSpecials: Unknown tclass 127 in savegame
The error on the demo/opening scene doesn't occurs anymore. Instead I can see a very fast blink of the HUD before the menu/Doom 64 logo appears.

Thanks kaiser for you awesome work.

Share this post

Link to post

I'm not having any issues with the game being superbright either. Is it when you change texture filtering from linear to nearest? I tried that too and it is still working fine on my end.

I've played for a few minutes and noticed a few minor oddities.

- When I switched the music to external and then back to internal, the music didn't restart until I exited to MAP02.
- I switched the framerate to smooth (uncapped, I guess) and I noticed some of the sprites jumping up and down. It only happened while viewing it through the menu; in-game it seems to work just fine.
- In the blue key puzzle in MAP02, if I hit a switch to trigger one of the crushers, there would be this weird momentary blinking. It only lasted for a fraction of a second but I could reproduce it every time I triggered the crusher.
- I saved my game, died, and then loaded my game all on the same map (MAP02). When I loaded it, the music no longer played.
- I used the launcher to run my game. The launcher didn't close when the game started though. Is that intentional?
- The Menu Cursor option was a little confusing at first, but then I realized that it allowed me to use my mouse cursor to navigate and manipulate the menu. It feels a little awkward though as your not really able to scroll down to see more menu options without using the arrow keys.

I really like all the new options in this latest version in relation to the last version I had (not sure which is was now). Great stuff Kaiser! If I could make a suggestion in relation to the option menus. Would it be possible to make a option where the menu could be drawn with the small (message) font? It seems like that would make it easier to digest all of the various options when navigating the menu. It's just a thought though :)

Oh and my graphics card is a ATI Radeon HD 5600.


After a bit more playing, I just noticed that the weird flickering going on with the crushers in MAP02 happens in every map with any sort of moving structure. Doors seem to be immune to it (or maybe it's not as noticeable). The flickering looks like it's one of the textures blinking into existence just momentarily (I saw the "?" texture the most). It's really weird :O

Share this post

Link to post

If possible, take screenshots of these selected areas in Map02 (F5). I am curious to see whats going on.

Also do you have smooth framerate enabled? That could be the only thing I can think of that would cause that to happen...

Share this post

Link to post

Yea I had smooth framerate enabled. I'll disable it and see if that makes any difference. I'll also try and grab a screenshot of the bud in question (which is going to take some really good timing on my part).

Share this post

Link to post

Actually I think I know what areas you're talking about. I'll look at the interpolation code and see what I can do. It looks more like a bad timing issue between interpolated ticks.

Share this post

Link to post

Ok cool. Setting the framerate back to capped did fix the issue by the way. I couldn't get a screenshot so I decided to record a video. I don't know if it's worth anything now but here it is for good measure:


The flickering is a lot easier to notice in MAP03 with all of the morphing structures.

I also just got a crash when trying to load my save; perhaps it's similar to the other issues reported already. I uploaded my save game file and the crash log too so maybe it'll be of some use:


Share this post

Link to post

From what I am seeing in the crashlog, its a result of a certain thinker not saving and because that it wasn't saved and you loaded the savegame file, the interpolation code fails to interpolate that certain thinker and then crash.

I really hate Doom's savegame system

Share this post

Link to post

Me too. Definitely hate it.
I remember when id revamped the save system on from Doom 1.666 to 1.9, I forgot to make a backup copy of my saves and ended up losing all my progress back then. I won't forget that never.
Hope you can figure the problem with savestates, I think you'd need to fully customize that saving routine to properly save what's needed... I never got to know the Doom source code, and albeit my developing skills turned Java 6 years ago, I might remember some "pointers".

Share this post

Link to post

+ Default cameratarget to player->mo if no cameratarget is read from savegame file
+ Call P_RemoveThinker instead of Z_Free when reading tc_combine thinker from savegame file
Doubt this fixes ALL of the savegame problems, but this at least fixes two major ones that I've discovered. You'll probably have to resave because I doubt loading the savegame from the previous version will work.


Share this post

Link to post

Tried out the new build and got another savegame crash. It was working ok after 3 or 4 loads but I finally got a crash on the first secret level.


Good luck getting all of the savegame bugs ironed out. It sounds like it's a pain in the ass :(

I also noticed a few other things:

- The game doesn't save autorun. I have to enable it again every time I run a new game. Maybe that's intentional?
- This might be related to the issues with the save games, but the music would stop playing when a game is loaded. Specifically, it seems to happen when I save and then load in the same session. By the way, I'm using external .ogg for the music now. I know I already reported this but I thought I'd say it again since I decided to give the .ogg soundtrack a try.
- I tried playing in the 16:10 aspect ration at fullscreen. It worked pretty good but when I exited a map, the entire rendered screen would slowly squish itself horizontally until the intermission popped up. I'll try some other resolution combinations to see if it still happens.
- I got a weird crash on MAP28 after running around while all of the monsters were spawning in. It was one of those "This application has stopped working and must be shut down" sort of errors so I'm afraid I don't have anything more I can provide on it.

Share this post

Link to post
Mechadon said:

- "This application has stopped working and must be shut down"

I really hate those. I am surprised the exception handler failed to catch it unless its coming from SDL. Try reproducing this..

As for that secret level, when did you save?

Share this post

Link to post

Alrighty, I'll give MAP28 a go the next time I'm on to see if I can reproduce it.

If I remember correctly, I saved right before you jump down into the yellow lit room where you get one of the laser artifacts.

I ran the game again in the 4:3 aspect ratio at fullscreen and it didn't do that weird horizontal screen stretching thing like it did with the 16:10 aspect ratio.

I also ran into another bug while playing through MAP30, though I'm not able to reproduce it at will. After going through the blue skull door at the beginning, I hit the concealed switch to lower the stairs and I got an error and a crash. Unfortunately I seem to have misplaced what the error message said :(. But I recall it had something to do with an object or a *.obj file...something along those lines. I'll see if I can reproduce it as well.

Last thing - did the original game show the artifacts you've obtained on the HUD anywhere? I can't remember but it seems that in D64Ex they don't show up. Unless I'm missing something, would there be a way to draw the obtained artifacts on the HUD somewhere?

Share this post

Link to post

The N64 version as well as D64ex would display the artifacts in the automap. If you want to see the artifacts on your hud, you change the hud type to the TC version.

As for the annoying random crashes, are you using mp3s for the music? If thats the case, go into your config file and make sure this is set:

i_affinitymask "1"
This can be set through the console as well. This is probably not the solution but I am just assuming.

Share this post

Link to post

I'm still getting that tclass 48 and 43 errors in savegames from Hectic.

I can experience a minor glitchiness on the moving sectors of MAP03 with uncapped refresh rate. When VSync is on, no problems at all (really smooth), as Mechadon reported.

Finally, I saved in front of red door on MAP03, and when trying to reload I got the same tclass 128 error. I'm impressed now.

A minor suggestion: Is there a way to create a debug mode, or maybe saving a demofile or anything to really determine what's going on there? Save games in some maps work as expected (MAP01, MAP02 so far I've seen).

Share this post

Link to post
Tamhvm said:

I'm impressed now.

Impressed on how crappy it is? Either ways I'll keep looking at the savegame code. Also next time you report this, make sure you specify what's going on in the level like do you have chascam on, are there any active ceilings/platforms moving, etc.

Share this post

Link to post

Oh right, they do show up on the automap. I'm using the TC hud but I overlooked the artifact display. Very nice :)

I'm using .oggs for the music so I'm not sure if that makes a difference from .mp3s. i_affinitymask was set to 0 though, so I'll change that to 1 and see if there's any improvement.

So far I haven't been able to reproduce the crash on MAP28 or MAP30 but I'll keep at it.

Share this post

Link to post
Kaiser said:

Impressed on how crappy it is? Either ways I'll keep looking at the savegame code. Also next time you report this, make sure you specify what's going on in the level like do you have chascam on, are there any active ceilings/platforms moving, etc.

LOL, no, impressed at how savegames work in some maps, and don't work in others.

In this time I mentioned, no ceilings or platforms were moving, I just stood there in front of the red door, without the key. I don't like chasecam, it's always off.

I'll try to be pretty detailed and/or save video recordings about what I'm doing to be able to be helpful next time.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now