Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Disable mouse movement in FreeDoom

Recommended Posts

As the title says, I cannot get the mouse movement disabled in Freedoom.

Moving the mouse causes my character to move forward, strafe and backwards.

This is a problem because when there are hazardous jumps or lava to avoid, I cannot avoid it because my character falls in because I am trying to move him with just my WASD keys, but the aiming I do with the mouse causes my death.

Anyone have similar experiences and a solutions? The KEY BINDINGS area is where I see the configuration problems, but I am unable to clear the bindings to the mouse.

Disabling the mouse in SETUP also has no effect.

Share this post

Link to post

Freedoom isn't an executable. It's just a set of data. So any control issue you have with it, you'd have with Doom as well.

Freedoom is intended to be used with source ports, not "vanilla" Doom (more precisely, it needs a Boom-compatible port), so tell us which engine you're using.

Share this post

Link to post

Most maps would crash vanilla anyway. Whatever port he is using likely has an option to turn off "vertical mouse movement" in the menu or to set "m_forward 0" in console.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now