Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
neubejiita

Strange ZDoom v2.5.0 - SVN revision 2508 BUG. [SOLVED]

Recommended Posts

I was playing TNT MAP09 with 3 bots at the start of the map and I ran out of ammo for the shotgun and there was a dropped shotgun beside a dead shotguy, but when I walked over it about 4 times I could not pick it up. But when I opened the door into the building and walked over some corpses there I could pick up the shotguns there and it worked, but why did I have problems picking up the shotgun outside, which the shotguy dropped?

Did the game suddenly decide that it had no ammunition in it and I could not pick it up? Very strange. I am running a x64 Linux build of Zdoom BTW.

Share this post


Link to post

This can happen if the item is in a position where a collision cannot be detected. Was it near any stairs or other sector height differences?

Share this post


Link to post

No, it was just sitting in the open, nothing really near it. Actually I just played again and I realised that it was co-op mode and I killed the shotguy, picked up his gun, and one was left there as `weapons stay` was turned, on.

So I was just confused for a second, sorry about that.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×