Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  

Command-line PrBoom+ in OSX

Recommended Posts

The maintainers don't support these switches, so I can't make a bug report.  But supposedly they work.  So, am I being a unix n00b again, or has this behavior changed between that post (PrBoom+ 2.4.0, Mac OS 10.4.5) and now (PrBoom+, Mac OS 10.6.4)?

open PrBoom-Plus --args -nomusic -width 640 -height 480 -fullscreen -complevel 3 -iwad doom.wad -warp 1 1 -skill 4

Share this post

Link to post

It still works fine for me.

Im unfamiliar with the way you are opening the program however. Typically what I do is navigate to the application in the terminal with (assuming its in the Applications folder)

cd /Applications/PrBoom-Plus.app/Contents/MacOS/

and then for example

./PrBoom-Plus --args -nomusic -width 640 -height 480 -fullscreen -complevel 3 -iwad doom.wad -warp 1 1 -skill 4

I just tested it and it worked fine for me....

Share this post

Link to post

woohoo, it works!  This is what I meant by "unix noob"...

I still get some SDL fruit salad but I'm assuming that can be worked out.  My everlasting gratitude!  You've saved me from the horrible fate of having to keep a Windows box working just to make demos!

Share this post

Link to post

Glad it worked for you mate.

If you want to get really tricky, you can always make your very own shell script which basically saves you from typing out all that rubbish every-time you want to record a new demo. PM me if you want help setting it up

Share this post

Link to post

I appreciate that offer, but actually I know how to do that part (it's come up at my office).

Now I just port DB2 to C++, and I'm all set, right?  :D

Share this post

Link to post
natt said:

What is a fruit salad?

Something like this — NSFW.  Rendering would look fine at startup and during fadeout, but as soon as I fired a shot or picked up an item (palette adjustment I guess), all was aglow.

IIRC this could be dispelled in older versions by hitting F11 (not that that's terribly convenient, though apparently I would use it when just screwing around in Maximum Doom), but no longer.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this