Custom texture problem in software renderer



Been using XWE for texture/patch work, not sure what the issue is.

I normally use GL mode so i had no idea for a while this problem existed, but if I ever release any wads I'd like them to be software compatible as well seeing as many people enjoy the classic feel and or don't have the means to utilize GL.

Help much appreciated and sorry in advance if this has been covered before, I did a search and skimmed a bit, but found nothing.

My best guess so far is it has something to do with the custom texture sizes. I hope this is not the case, but these specifically are 24Wx72H...

Share this post


Link to post
GoatAvenger said:

I hope this is not the case, but these specifically are 24Wx72H...

ZDoom renderer brokenness. It requires textures height to be a power of two (like vanilla) for vertical tiling to work properly. Apparently Randy is with love with his renderer and refuses to fix it. Boom and its derivatives render it properly.

Share this post


Link to post

This is a bug I saw long ago a couple times. The screenshot below is in ZPack E1M2, the texture N5COMP4C is 72 tall. It only shows this problem in the software renderer, so I guess it's the power-of-2 problem.

Share this post


Link to post

I find it very bizarre that ZDoom still has this problem, especially given the fact it otherwise has such a flexible texturing system. The fix isn't that complicated, either.

Share this post


Link to post

My best guess is it hasn't been fixed due to most people using openGL once it was available. The bug isn't there in openGL so...

Anyway, thnx, for the help tempun. I suppose i'll have to try resizing textures or just say to hell with software mode.

Share this post


Link to post
Quasar said:

I find it very bizarre that ZDoom still has this problem, especially given the fact it otherwise has such a flexible texturing system.


For those who are interested. It finally got fixed today.

Quasar said:

The fix isn't that complicated, either.



I guess the reason was that ZDoom's column drawer was aggressively optimized for power-of-two textures. So in essence the new code to allow these textures can be considered a bit of a hack.

Share this post


Link to post

havent seen this in GZDoom

but zdoom has these problems, causing more problems in people's thoghts about how hard it is to add a texture :/

Share this post


Link to post

Not anymore. As I said, it was fixed today.

GZDoom never had this problem because proper texture tiling is automatic with hardware rendering (unless you try to do strange things with your textures - which no Doom GL port does.)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now