Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
NaturalTvventy

invisible floor

Recommended Posts

Greetings,

I'm having some trouble with the invisible floor trick, a-la UAC_DEAD. I've got a big pit I want the player to be able to magically run across. So I put a self-referencing sector in there and that should be that, right? Well, it was that, at least at first. It worked fine for a while, but all of a sudden it doesn't any more. I've checked the wiki to see if there's something more to it, but it doesn't say anything. I've checked various WADs that use the trick, and I can't see what I'm missing.

Here's a WAD with the room I'm trying to make have the pit. (IWAD doom.wad, e1m1)

http://www.mediafire.com/?bt8glkx9arb22dv

Any help?

Thx,

NT

Share this post


Link to post

hmm.. tried your method Earthquake. Didn't seem to do the trick. Basically your method, if I am understanding it, is to draw a sector around the self-referencing sector, nice and close (1 unit). didn't do anything except limit the flat spilling over due to no lower texture. Am I missing something?

Share this post


Link to post

Did you make the dummy sector (for ease of use) and change the references to the actual platform sidedefs (not border) to that of the dummy sector?

You want to change both sidedefs for each line of the platform.

Share this post


Link to post

figured it out. it's one of those kooky doom things. apparently the invisible sector needs to be a higher sector # then the sector around it. Someone should update the wiki....

Share this post


Link to post

Here is an example map:

http://www.speedyshare.com/files/29362673/illusioplat.wad

The top part is me laying out the sectors.

The middle part is after I merged the dummy sector with the platform sector, and moved the border lines closer to the platform.

The bottom part is after changing the sidedefs of the platform to match that of the dummy sector. Note that the merging of the two sectors in step two makes the inner sidedefs of the platform lines the same as those of the dummy sector. At this point, you just need to change the platform sidedefs facing the border linedefs.

Got all that? :p

Edit: well poop, okay... well... glad you got it!

Share this post


Link to post

I tried this in skulltag and zdoom, and the order of the sector numbers does not matter. It works both ways.

Share this post


Link to post

I see it also depends on the node builder. A normal closed platform works regardless, but when I tried to make some geometry inside the platform, zennode did not make the platform at all, and zdbsp makes unintended platforms outside the platform stretching until the walls of the room

Share this post


Link to post
Zom-B said:

I see it also depends on the node builder. A normal closed platform works regardless, but when I tried to make some geometry inside the platform, zennode did not make the platform at all, and zdbsp makes unintended platforms outside the platform stretching until the walls of the room


Some nodebuilders try to optimize the node structures by ignoring 2-sided linedefs where both sidedefs reference the same sector. In most normal cases, this will not produce any odd effects, as each side of the linedef is the same sector and has the same properties. But when doing vanilla tricks like the invisible platform where unclosed sectors are used, this will probably cause problems.

I reckon that zennode does this automatically (or you have the option to enable this checking turned on), which would explain why it wouldn't work. For the record, the above test map was built using DeepBSP with the "ignore 2-sided linedefs" option off.

Also, the "leaking" behavior is normal. This is why you should always enclose the invisible platform with a "border" to prevent surrounding areas from carrying the properties of the invisible platform. The border will stop the flooding effect as long as long as you don't have the "ignore 2-sided linedefs" option working against you.

Share this post


Link to post

I don't know if it really matters, but I always keep subsectors from intersecting self-referencing sectors, seems to keep them from acting nuts under different nodebuilders.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×