Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
xvertigox

Hud size in PrBoom+

Recommended Posts

Is there any way to change the scale of the pro PrBoom+ hud (new hud, not original doom status bar)? It's too small for me on 1600x900.

Share this post


Link to post

For some reason it doesn't do anything, the hud size doesn't change with either a 1 or 0 :S

I just tried changing another cvar, this time autorun to 0 but autorun is still enabled :S It's like it's not reading from my config, is there an autoexec for prboom+?

Share this post


Link to post

Is the problem that the hud is smaller when you use higher screen resolutions compared to when you use lower screen resolutions or is that you want to make the hud bigger for all screen resolutions?

Share this post


Link to post

I just checked and I need it bigger for all resolutions. The hud is the same scale on 640x480 and 1600x900

Share this post


Link to post

I don't think the hud can get any bigger than that.

My only other suggestion is to open the cfg and change "hud_distributed" from 0 to 1 and "hud_active" from 2 to 3. This will give you a hud with larger numbers for health and armor, though everything else will be the same size.

Share this post


Link to post

Doesn't prBoom+ only do "clean", stretchless, integer resizes that don't alter the aspect ratio? In that case, there's no way you'll get a full-width stretch for a non 4:3 or 5:4 aspect ratio.

Share this post


Link to post
Doom_user said:

Open prboom-plus.cfg, find "render_stretch_hud" and change the 0 to a 1.

to 2 for "fit to width"

Maes said:

Doesn't prBoom+ only do "clean", stretchless, integer resizes that don't alter the aspect ratio? In that case, there's no way you'll get a full-width stretch for a non 4:3 or 5:4 aspect ratio.

There are three modes: "not adjusted" (integer resizes), "doom format" (4:3) and "fit to width".

Also there are two settings for custom scaling when "not adjusted" is used:
render_patches_scalex 0
render_patches_scaley 0


640x360:


800x450:

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  
×