Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
sirjuddington

SLADE v3.0.2

Recommended Posts

SlayeR said:

Is released. Next up: the map editor (again) :)


Here's a little problem I encountered:

I'd imported sprites with a random coloured background, which I intended to set as the transparent colour whilst converting to Doom Format, BUT as there is no colour sampler, I couldn't get the exact colour right, so it didn't turn transparent.

Share this post


Link to post

Oh, neat--

- Typing the first few characters of an item to jump to it in lists has been re-implemented


OMG maybe I can finally switch over to this full-time now :D

Share this post


Link to post
SlayeR said:

Another thing that needs to be looked at is some proper documentation of editor features, but this is one of those things I'm not so good at, I wouldn't know where to start :P

Make a list of SLADE features and whenever someone asks you about a feature, write about it.
Also, a quick request: a button to generate Boom color translation lump in color remap dialog.

Share this post


Link to post

Will it have an option to launch DB2 for map editing?

The path where DB2 is installed can be found in the registry at HKEY_LOCAL_MACHINE\SOFTWARE\CodeImp\Doom Builder\Location
The arguments to pass to DB2 are documented here and if you need any special argument you can ask me ofcourse :)

Share this post


Link to post

Doom Builder 2 and Slade rock, if they can be used together that would be awesome, the closest I have at the mo is the two executables for them both next to each other on rocket dock. Would be awesome if they worked together though. Especially with the new hexen format previewing in DB2.

Share this post


Link to post
CodeImp said:

Will it have an option to launch DB2 for map editing?


I'm sure an option to specify ANY custom editor could be sensible for the time being but when SlayeR puts in the map editor, it might not be in his best interests to do so.

Share this post


Link to post
phobosdeimos1 said:

I'd imported sprites with a random coloured background, which I intended to set as the transparent colour whilst converting to Doom Format, BUT as there is no colour sampler, I couldn't get the exact colour right, so it didn't turn transparent.

That's something that has been requested before. I'll probably add it for the next version. For now just use an easy-to-select colour as the background, such as cyan or magenta. Also if the image you're importing is paletted, it's not quite as hard to select the right colour.

As for launching DB2, it could probably be done. It'd need a parameter to set resource wad/pk3s though.

Also, if anyone wants to post in news submissions about this, feel free :P I don't think any 3.x release has been news'd here yet.

Share this post


Link to post
Csonicgo said:

it might not be in his best interests to do so.

Because then people have the option to use them together easily instead of one alone or with hassle? I don't see logic in your opinion; they will probably use slade for wad management anyway. Either way, I would like to hear Slayers opinion as this is really something for him to decide.

Edit: Slayer beat me. But im at a disadvantage when typing on a cell phone :P
Thanks Slayer. I'll have a look at that parameter.

Share this post


Link to post

Very nice, thanks for continuing your work on this SlayeR. I've been a heavy user of Slade3 for a long time now and it has been very, very helpful. Looking forward to the map editor as well :D

Share this post


Link to post

Slayer; I have added that parameter. Documentation has been updated.

Also, if you figure something isn't launching right as you expected, check out the log file DB2 writes to see if anything went wrong with the command line parameters (it will be near the top of the log). You can find the log file at these locations:
Windows XP: C:\Documents and Settings\Username\Local Settings\Application Data\Doom Builder
Windows Vista: C:\Users\Username\AppData\Local\Doom Builder

Now I guess I'm going to have to work on a new official DB2 release, because people will need this new DB2 version if they want it launched from Slade.

Thanks for your cooperation!

Share this post


Link to post

SlayeR: you might want to add an option for DeepSea or a custom editor in the future as well, if that is already possible.

Share this post


Link to post
Csonicgo said:

SlayeR: you might want to add an option for DeepSea or a custom editor in the future as well, if that is already possible.

Unless DeepSea and other editors are going to implement parameters like what SlayeR and CodeImp just discussed to be able to actually load them with certain maps and resources, it wouldn't be much more useful than a shortcut button that you could start Solitaire with.

Which there should be, btw.

Share this post


Link to post
CodeImp said:

Now I guess I'm going to have to work on a new official DB2 release, because people will need this new DB2 version if they want it launched from Slade.

I don't think that next Slade release will be made any time soon.

Share this post


Link to post

While DB2 being launched from Slade is probably a good idea, I really hope it doesn't stifle Slade's own map editor, because of the fact that I personally can't run DB2 on my box. So yeah. Yet Slade is easily compiled.

Share this post


Link to post
shadow1013 said:

While DB2 being launched from Slade is probably a good idea, I really hope it doesn't stifle Slade's own map editor, because of the fact that I personally can't run DB2 on my box. So yeah. Yet Slade is easily compiled.

Heh don't worry, it won't :P Launching DB2 will just be for user preference for the most part. Of course it won't be as tightly integrated with the main editor, eg. changing a texture in SLADE will update it in the SLADE map editor, but won't update in DB2 unless you close/reopen it.

Share this post


Link to post

Awesome, SLADE 3 is the best Doom resource manger I know about.

Csonicgo said:

SlayeR: you might want to add an option for DeepSea or a custom editor in the future as well, if that is already possible.

People still pay for DeepSea?

Share this post


Link to post

There are two features I'm still missing, which XWE has

1. Visually sorting the Entries table by clicking on the column headers

2. Quickly browsing through the maps (filtering the list by Maps also shows all the map-related lumps, which makes browsing awkward to say the least)

For point 2, I would prefer the map list on the lower part of the Archive panel to open the map for viewing in the contents panel, when selected, in addition to invoking the map editor when double-clicked)

Share this post


Link to post
Zom-B said:

2. Quickly browsing through the maps (filtering the list by Maps also shows all the map-related lumps, which makes browsing awkward to say the least)

type E?M or MAP into filter field

Share this post


Link to post


You have to type 'map' in Filter. If you select Map from Show, then the namespace lumps are also displayed, not just the maps.


so, XWE is still easier to use. Just click on the category and wham there it is.

Share this post


Link to post

I found a bug.

Make a PNG file, add it to a texture wad, add the texture to the PNAMES lump, rename the texture, rename the PNAMES entry of the texture, change the PNG file, add it to the texture wad again (there are two different textures now), add to PNAMES, go to the TEXTURE# editor

note that both PNAMES entries show the same image, even though they are different. Saving the WAD and restarting SLADE resolves it.

Share this post


Link to post
Kappes Buur said:

so, XWE is still easier to use. Just click on the category and wham there it is.

Heh, well only slightly :P Plus IMO the category buttons are quite ugly and add to clutter.

Zom-B said:

I found a bug.

Make a PNG file, add it to a texture wad, add the texture to the PNAMES lump, rename the texture, rename the PNAMES entry of the texture, change the PNG file, add it to the texture wad again (there are two different textures now), add to PNAMES, go to the TEXTURE# editor

note that both PNAMES entries show the same image, even though they are different. Saving the WAD and restarting SLADE resolves it.

Could you be a bit clearer with the steps? I find that pretty hard to follow.

Share this post


Link to post
Kappes Buur said:

so, XWE is still easier to use. Just click on the category and wham there it is.

Not really; XWE's behavior of not showing the relevant namespace lumps actually seems pretty useless if you want to find a map to actually do something with it, like copying it or moving it, given that the marker lump by itself doesn't actually do anything.

Share this post


Link to post
SlayeR said:

Heh, well only slightly :P

Agreed, I'm just saying.

esselfortium said:

Not really; XWE's behavior of not showing the relevant namespace lumps actually seems pretty useless if you want to find a map to actually do something with it, like copying it or moving it, given that the marker lump by itself doesn't actually do anything.


I was simply referring to the case where one wants to quickly scan through the maps. However, for that I'm really looking forward to this feature



I wished it could be moved up in priority.

Share this post


Link to post
SlayeR said:

Heh, well only slightly :P Plus IMO the category buttons are quite ugly and add to clutter.


Could you be a bit clearer with the steps? I find that pretty hard to follow.

Sorry, I didn't see this reply before.

The steps are just like that. If you are unsure of any steps, ask me.

1. Make a PNG file,
2. add it to a texture wad,
3. add the texture to the PNAMES lump,
4. rename the texture,
5. rename the PNAMES entry of the texture,
6. change the PNG file,
7. add it to the texture wad again (there are two different textures now),
8. add to PNAMES,
9. go to the TEXTURE# editor
10. note that both PNAMES entries show the same image, even though they are different. Saving the WAD and restarting SLADE resolves it.

Share this post


Link to post

I found a bunch of other bugs in the TEXTUREx parser.

All files involved:
no_bug.wad (just Doom2 1.9's TEXTURE1 and PNAMES lumps)
bug1.wad (changed from no_bug.wad)
bug2.wad (changed from no_bug.wad)
bug2.wad (changed from no_bug.wad)
bug4.wad (original, saved with faulty algorithm)
fixed.wad (same origin as bug4.wad, but saved with good algorithm)

Bug #1
When the length of the TEXTURE1 lump in the WAD directory is recorded wrong, smaller than actual, the Texture Editor tab will be missing the TEXTURE1 tab, and a corrupteed gui element is visible in the upper-left corner of the pane:



How to reproduce:
1. Open no_bug.wad in a hex editor
2. find the string TEXTURE1 (address 0x61C4)
3. go back 4 bytes (address 0x61C0 in no_bug.wad)
4. change the 32-bit little-endian integer to a lower one (default: 0x00005304, change to eg. 0x00005000)
5. save (bug1.wad)
6. open in slade
7. open TEXTURE1 in the Texture Editor
8. Corrupt panel is visible without the TEXTURE1 tab.

Bug #2 - #4:
When the header of the TEXTURE1 lump is corrupt, one of three bugs can happen.

See: http://doomwiki.org/wiki/TEXTURE1_and_TEXTURE2

How to reproduce bug #2:
1. Open no_bug.wad in a hex editor
2. change the numtextures entry (address 0x0C) to a number higher than original (eg. 0x00004321)
3. save (bug2.wad)
4. open in slade
5. open TEXTURE1 in the Texture Editor
6. the Texture Editor panel flashes real quick and disappears before you notice it.

How to reproduce bug #3:
1. Open no_bug.wad in a hex editor
2. change the first offset entry (address 0x10) to a number higher than original, and which is not the start of an actual maptexture_t entry (eg. 0x00003333)
3. save (bug3.wad)
4. open in slade
5. open TEXTURE1 in the Texture Editor
6. Same effect as Bug #1 happens

How to reproduce bug #4:
1. I don't know how it's corrupt, so just open bug4.wad in slade
2. open TEXTURE1 in the Texture Editor
3. note that it erroneously detected the "Nameless (Doom Alpha)" format.
4. Whenever you click a texture in the list, it crashes the app.

Share this post


Link to post

One big problem I have, which SLumpEd doesn't, is that you need a .sf2 file to play music files. Which doesn't make sense because I have no idea how to use an .sf2 file for music in ZDoom. Care to fix that sometime soon?

Share this post


Link to post
colBoh said:

One big problem I have, which SLumpEd doesn't, is that you need a .sf2 file to play music files. Which doesn't make sense because I have no idea how to use an .sf2 file for music in ZDoom. Care to fix that sometime soon?

ZDoom uses FMOD for MIDI playback, which uses system default soundfont. FMOD is not GPL compatble. It was used in SlumpEd, but it was a Bad Idea™. Slade uses FluidSynth, which doesn't support DLS format used on Windows, so you need to get a soundfont in SF2 format. (At least on Windows.) A soundfont very similar to Windows default, but in SF2 format, can be found here.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×