Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Eponasoft

Trouble with MAPINFO/Intermission

Recommended Posts

Trying out the Intermission capabilities with the new MAPINFO format but having some issues. Here's my relevant MAPINFO configuration:

intermission CUTSCENE03
{
	TextScreen
	{
		Time = -10
		Background = "INTR3"
		Music = "INTRLUDE"
		Position = 20, 140
		Text = "Intermission text test!"
	}
}
and
map E1M4 "The Road To Kricek"
{
cluster = 1
enterpic = "$CUTSCENE03"
exitpic = "COMPLETE"
sky1 = "SKY1", 0
next = "E1M5"
secretnext = "E1M5"
par = 120
music = "LEVEL04"
}
and here's the result:



The directions on the wiki are followed to the letter... as far as I can tell. Since this is a newer feature, I haven't been able to find much information on why this is happening, since there have apparently been virtually no posts on this feature on both this site or on zdoom's forums.

And yes, gzdoom as before, latest version. :)

Share this post


Link to post

Hmmm, Try this:


map E1M4 "The Road To Kricek"
cluster 1
enterpic "$CUTSCENE03" //for 'Now entering:' when going to this level
exitpic "COMPLETE" // Background for leaving this level.
sky1 sky1 0
next E1M5
secretnext E1M5
par 120
music LEVEL04

ClusterDef 1
Pic "your_pic" //This is the backround for the message.
Entertext "Wheeeeeeeeeeeeee!"


The images used for the backgrounds can be JPG, didn't test any others.
Also im unsure if the "$" is needed.
Try and let me know if it fixes anything :/

Share this post


Link to post

That's the old style. That was actually what I was doing before the new version came out with explicit support for proper intermissions. The old way *worked*... sort of... but it meant I could only use a single image for the intermission, all the text had to fit on one screen, and every level had to have its own cluster, which also meant that affecting other maps would be impossible (since they have to be in the same cluster for this to work, apparently). MAPINFO/Intermission should eliminate all of these problems... if I could only get it to work. :(

IMO, they should have called it "cutscene" rather than "intermission", since "intermission" is already a "taken" phrase in the DOOM modding world...

Share this post


Link to post

Alright, there's a confusion between different types of intermission...

Eponasoft said:

enterpic = "$CUTSCENE03"
and here's the result:

http://www.nodtveidt.net/intermission_error.png


The $ in front of the name tells it to use an intermission script contained in a separate lump. An intermission script like this.

You get an error message telling you that the CUTSCENE03 lump was not found because it doesn't exist.

What you're trying to do is a different type of intermission, which cannot be used as an enterpic or exitpic because it's a different thing from the "Level completed/Now entering" intermission. You've got to use "next" or "secretnext" instead if I'm not mistaken. (I'm not very familiar yet with them honestly.)

Share this post


Link to post

Ah yes, that has to be it... no problem then, I can put it in a lump and that should be the end of it. Thanks.

And yeah, the confusion exists because Intermission is already an established term. That's why I specified this as MAPINFO/Intermission... it's an actual entry in the MAPINFO lump now. It really should have been called Cutscene or something like that...

Doing the next/secretnext way is something I've seen in some pwads in order to create complex cutscenes, but that requires a specially designed map. It's a total kludge. This appears to be a clean solution to it.

Anyway, I'll give it a shot and see if it works. Thanks again for the tip.

EDIT: Well, it would have worked if that was the problem... but it wasn't. The intermission actually DOES go inside MAPINFO itself. However, I'm now at a loss for how to call it up.

The relevant zdoom doc states this:

This defines the picture which is used as the backdrop for the 'entering Level' screen. If none is specified the current game's default will be used. If the name is preceded with a '$' the lump will be used as an intermission script.


which then points here:

http://zdoom.org/wiki/Intermission_script

which is NOT what I want. This is a feature inside of the MAPINFO lump itself. I can only think of a few things to try from here:

-Putting the MAPINFO/Intermission data between E1M3 and E1M4
-Naming the intermission E1M3 or E1M4, depending on which one it should be
-Assuming the MAPINFO/Map document was never updated and is missing crucial information

Something has to work, so I'm going to keep at it until I figure it out.

EDIT2: MAPINFO/Intermission is USELESS for what I need it to do.

http://forum.zdoom.org/viewtopic.php?f=3&t=30072

reveals why. Apparently, you can only use it as an endgame sequence. That's severely limiting and makes it completely useless as a between-level storyline device. Sure, it's great for making interesting endings, but for doing scenes between levels, it looks like it's not going to work.

Share this post


Link to post

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×