Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Deimos2k11

Doomsday - Mouse is stuck!

Recommended Posts

Hello Everybody! It seems nobody else got this problem until now, so here's the problem:
I'm playing actually with Doomsday, it runs fine until 1.9.0 beta5.1, but when I save the game to a slot, it crashes and a window appears:

http://deimosproduction.altervista.org/images/Fails/error.PNG

and this is the logfile:
http://deimosproduction.altervista.org/images/Fails/Doomsday.out.txt

I looked around on the forums and I found that this problem looks fixed from ver. 1.9.0 beta6 and later, but I cannot install and play with anyone of the beta6.x versions because I got the mouse "stuck" on X/Y axis, while all the buttons work fine. I cannot play without mouse, so I pulled out and plugged in the mouse to see if it worked, changed mouse, played with settings (both in the control panel and the in-game menu)... No way, it doesn't move. I'm thinking to try some old ps2 port instead usb, but actually I haven't a mouse that fits in that port, so what am I doing wrong here? Any help would be appreciated!

Share this post


Link to post

Sounds like you installed that version over the top of a previous install rather than doing a fresh install (we mentioned this in the changelog and release announcements at the time). A fresh install is pretty much required between those versions because the organisation of the install directory was changed significantly and the control binding syntax was completely replaced. The latter is more than likely the cause of the problem (i.e., you are attempting to load an obsolete and unsupported config). Look for jdoom.cfg, make a backup and then delete the original, allow the engine to recreate it.

Also the reason for the "crash" is there right in your log file, its the very last line:

Deimos2k11's doomsday.out file said:

SV_ThingArchiveNum: Thing archive exhausted!

This is effectively this bug in DOOM (although it has since been addressed, along with countless other fixed limits inherited from vanilla): http://doom.wikia.com/wiki/Savegame_buffer_overflow

I would strongly recommend upgrading from 1.9.0beta5.1

Share this post


Link to post

Hi, tnx for answering. You were right! Fresh install and the mouse is working again. I think my fault was just to install the later versions OVER the previous ones, although I've already tried to re-instal the latest version after having beta5.1 completely uninstalled, including all its files and the main Doomsday folder deleted... I guess there was some .cfg file leftover I was forgetting to delete :-)
Tnx for your support!!!

Happy Dooming...

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×