Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
purist

Legacy Joypad

Recommended Posts

I used to like using the launcher in Legacy 1.42 to set up splitscreen co-op games and it worked fine for vanilla maps or most PRBoom+ compat maps as long as there was no reliance on voodoo dolls.

I thought my problems were solved with Legacy 1.44 alpha 3 as it supports voodoo dolls but I keep running into niggly errors.

First, 1.44 doesn't include a launcher. This isn't a massive issue as the 1.42 launcher still works with the new version but for some reason it doesn't read joypad states - even when USB joypad is enabled in the launcher. I can't find any in-game option to enable this.

Second, 1.44 doesn't save my settings. This is more annoying because it defaults to a video mode that's not compatible to my screen and I think the controls go back to default too. 1.42 saves my settings on exiting.

I'm pretty useless without a very inuitive user interface so I've probably missed some config setting. Can anyone help?

Share this post


Link to post

I am going to guess that you are using win7 or Vista, because of the config saving issue. On these windows platforms, there are reports of the config file going missing because of directory path issues. However, without a windows developer (all Linux developers) we are dependent upon some windows user determining a fix.

Might try specifying a config file on the command line using an absolute path ??

Launchers depend upon the command line parameters.
The command line has gotten some modifications for 1.44, so previous launchers may have problems, but an upgrade of their control strings should fix it.
Everything should be controllable from the menus and console, which is the major reason the launcher is not needed anymore.
Any control value that the launcher could change, the console can change by setting the value of the control variable.

I do not remember a joypad control, having never used one, but I will look. It might be there.

There are considerable docs for console and command line parameters that have been updated recently. They come with the binary and source downloads.

We have been fixing Bug reports (SourceForge), but ones that concern Windows are tough to deal with.

The split player and multiplayer menus got reconfigured in the latest svn version. Returns the main menu to a Plutonia2 compatible form.
Multiplayer menu now allows both players to be setup before the game is started (previous versions required two trips through the menu).

Wesley Johnson, DoomLegacy Development

Share this post


Link to post

Win XP. I couldn't find a joypad enable flag in the menu - didn't try the console. You can bind certain actions to it so it acknowledges it's there but you can't bind actions to the DPad or analog stick so it's useless.

I'm not sure about enabling through command lines. I wouldn't know what to type. I'd love to be able to help you find fixes but beyond reporting the problems in as much detail as possible I can't be much use because I simply don't have the technical knowledge.

I'm also getting errors for maps that work in PRBoom+ but cause Legacy to crash but I want to investigate the map before bothering you with the details because I've managed to apply simple fixes to restore Legacy compatability before.

Hopefully these things will be cleared up in future versions. Legacy is the only port I download each new version of. I'm almost willing it to work perfectly :-)

Share this post


Link to post

Looking at the notes, the joystick controls was one of the things that got modified in 1.44 alpha1. It appears to now map better to the SDL and directX capabilities. It appears that you must use the console to setup joystick (or similar devices). Not having used one, I do not quite understand it. It appears to be generic enough to handle a wide range of joystick devices. The launcher setup of joystick is not going to work any more, although other parts of launcher will still work.
You are going to have to investigate the console. See the docs directory, it explains the console commands.

There is also an extensive command line docs in the same directory.
I think XP has a startup object that has a way to enter command line switches for the program.

If we hear from enough joystick users, this probably could get some menu setup page. There is a DoomLegacy feature request page at sourceforge.

If you continue to have problems, I can pass questions to the developer that made that change. Answers may not be quick.

Look around your directories and see if there is a doomlegacy config file somewhere. We have heard of it ending up at the root directory, c:

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×