Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Rafeinator

Glitches in Doom Builder 2 Testing

Recommended Posts

I'm relatively new to making custom maps with editors, but I was doing pretty well up until yesterday, when I started getting these strange glitches when trying to test maps.

I'm editing with doom builder 2 and I'm using the jDoom/Doomsday engine for testing.

I've confirmed that the glitches only seem to happen in the two following scenarios:

- if I create a single sector, place a start point in it and try to test the map, it will immeadiately crash with a "segmentation violation" error. Also, in doomsday out it says "W_AddFile: ERROR: T:\Administrator\Temp\59brehhd\mshdwrxo.wad not found!".

however, if I create a map with more than one sector,it at least loads and I can play it. That being said,

- if I create a sector and then create another sector within the first that shares one or more of the first's linedefs, it makes some textures disappear. Generally it seems to be the wall and some of the floor next to where the two sectors share a linedef. You'll either just see the sky through where the wall and floor used to be or get a HOM effect. (Also, the map looks fine when viewed through doom builder's 3D editing mode.)

This has completely baffled me as everything was working fine for about a week. I would be extremely grateful to anyone who can shed some light on this.

Share this post


Link to post
Rafeinator said:

- if I create a single sector, place a start point in it and try to test the map, it will immeadiately crash with a "segmentation violation" error. Also, in doomsday out it says "W_AddFile: ERROR: T:\Administrator\Temp\59brehhd\mshdwrxo.wad not found!"

If you want one-sector-maps don't make that sector convex.

Rafeinator said:

- if I create a sector and then create another sector within the first that shares one or more of the first's linedefs, it makes some textures disappear. Generally it seems to be the wall and some of the floor next to where the two sectors share a linedef. You'll either just see the sky through where the wall and floor used to be or get a HOM effect. (Also, the map looks fine when viewed through doom builder's 3D editing mode.)

Don't really know what you mean, works fine for me.

Share this post


Link to post

Thanks, Boris!

I tried the concave sector, and it worked.

Then I tried replicating that second glitch, and it didn't happen, either. I'm not sure what caused that, but I glad it's gone.

I guess this thread can be closed now, but before it is, can you give me a quick explanation of why single sector maps can't be convex? I'd like to know just out of curiosity.

Share this post


Link to post
Rafeinator said:

I guess this thread can be closed now, but before it is, can you give me a quick explanation of why single sector maps can't be convex? I'd like to know just out of curiosity.

Doomsday authors consider this to be a bug.

Share this post


Link to post

The problem here is a regression in the current release of Doomsday which doesn't consider the case of BSP "tree" consisting of a single subsector. This problem has since been addressed but we aren't yet ready to release a new version.

There is no technical reason why a single sector map can't be convex. The current behaviour is merely a bug.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×