Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
dannebubinga

autoload from .bat? prboom+

Recommended Posts

Hi!

I was speed running ngmvmt1.wad today and got bit of a seizure and gave my keyboard a punch :) Now when I open the .bat file to record, the game starts from a previous save that I made by mistake when I was about to quit.

The parameters in the .bat file is as usual but like I said, it loads a save game instead of -warp 04. I want this to go away of course, but I don't know how.

This is the parameter I use:
c:\\doom\sourceports\prboom+\glboom-plus.exe -iwad doom2.wad -file ngmvmt1.wad -warp 04 -skill 4 -record ngmvmt04

Share this post


Link to post

I think it happens if you save during recording. A useful feature for TAS demos.
Try rewriting this savegame while not recording.

Share this post


Link to post

I followed your advice but it din't help. I erased the old save game files - started the wad without recording and saved 3 times at the start of map01. When I opened the .bat file the game loaded the save from map01.

This must be some kind of option that I by mistake changed when I smashed my keyboard?

Share this post


Link to post

set demoname=ngmvmt04_%date:~6,4%-%date:~3,2%-%date:~0,2%_%time:~0,2%.%time:~3,2%.%time:~6,2%.%time:~9,2%.lmp
start glboom-plus.exe ngmvmt1.wad -warp 4 -skill 4 -record %demoname%
?

Share this post


Link to post

Hmm. I used prboom+ and recorded a demo. When I later tried the original .bat file wich launches glboom+ it worked. Very strange.

Chungy: should I put that in the .bat or in the cfg?

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
×